Bug 1649093 - "dnf kickstart mykickstart.ks" crashes with AttributeError: 'BaseCli' object has no attribute 'install_grouplist'
Summary: "dnf kickstart mykickstart.ks" crashes with AttributeError: 'BaseCli' object ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1628512 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-12 22:39 UTC by Edgar Hoch
Modified: 2019-10-25 18:08 UTC (History)
6 users (show)

Fixed In Version: dnf-plugins-extras-4.0.7-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-25 18:08:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Edgar Hoch 2018-11-12 22:39:47 UTC
Description of problem:
"dnf kickstart mykickstart.ks" crashes with AttributeError: 'BaseCli' object has no attribute 'install_grouplist'.

# dnf kickstart mykickstart.ks
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 1055, in run
    return self.command.run()
  File "/usr/lib/python3.7/site-packages/dnf-plugins/kickstart.py", line 88, in run
    self.base.install_grouplist(group_names)
AttributeError: 'BaseCli' object has no attribute 'install_grouplist'


Version-Release number of selected component (if applicable):
python3-dnf-plugin-kickstart-3.0.2-1.fc29.noarch

How reproducible:
Always

Steps to Reproduce:
1.dnf kickstart mykickstart.ks

Actual results:
Error, see above.

Expected results:
(Missing) packages from kickstart file should be installed.

Comment 1 Jaroslav Mracek 2019-06-30 19:23:45 UTC
I am not a user of kikstart plugin, but I am able to provide a patch. Do you think it will be possible to ask you to test patched plugin?
Just tell me what version of Fedora you will use for testing.

Comment 2 Jaroslav Mracek 2019-07-01 06:01:49 UTC
I created a patch https://github.com/rpm-software-management/dnf-plugins-extras/pull/156 but it requires additional testing. Anyone could help? I can provide builds just provide a distro and version.

Comment 3 Edgar Hoch 2019-07-01 08:54:27 UTC
Jaruslav, thanks for your help!

I would prefer testing for Fedora 30, but I can also use Fedora 29.

Comment 4 Jaroslav Mracek 2019-07-01 09:07:17 UTC
The build for Fedora 30 is in copr repository. To enable it just run "dnf copr enable jmracek/kickstart" (https://copr.fedorainfracloud.org/coprs/jmracek/kickstart/builds/). May be the installation will requires additional packages from our dnf-nightly (dnf copr enable rpmsoftwaremanagement/dnf-nightly).

Comment 5 Jaroslav Mracek 2019-07-03 16:53:20 UTC
*** Bug 1628512 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2019-10-15 11:08:46 UTC
FEDORA-2019-df11921f9a has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-df11921f9a

Comment 7 Fedora Update System 2019-10-16 00:14:21 UTC
dnf-plugins-extras-4.0.7-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-df11921f9a

Comment 8 Fedora Update System 2019-10-18 10:33:15 UTC
FEDORA-2019-7656a4dd09 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7656a4dd09

Comment 9 Fedora Update System 2019-10-18 21:54:35 UTC
dnf-plugins-extras-4.0.7-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7656a4dd09

Comment 10 Fedora Update System 2019-10-25 18:08:35 UTC
dnf-plugins-extras-4.0.7-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.