Bug 1649221 - Go to RS/RC Pods page when clicking pods selector on Overview
Summary: Go to RS/RC Pods page when clicking pods selector on Overview
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-13 07:49 UTC by Yadan Pei
Modified: 2019-06-04 10:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Pods are associated with Deployments and DeploymentConfigs using label selectors which causes a collision for Deployments and DeploymentConfigs with duplicate names. Consequence: It is possible for pods to be incorrectly listed on Deployment and DeploymentConfig 'Pods' tab. When linking to these resources from the overview page, the user might see extra pods listed. Fix: Instead of linking to the 'Pods' tab of the DeploymentConfig or Deployment resource, the pod status link on the overview page was updated to point to the 'Pods' tab of the underlying ReplicationController or ReplicaSet, respectively. Result: User will see correct pods listed when they click on the pod status link from the overview page.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:59 UTC

Description Yadan Pei 2018-11-13 07:49:30 UTC
Description of problem:
Clicking the N of N pod selector on Overview, it goes to Deployment/DeploymentConfig Pods tab, where unexpected pods are listed, it should goes to RS/RC Pods tab

Version-Release number of selected component (if applicable):
registry.reg-aws.openshift.com:443/openshift/ose-console:v4.0 with commit f83a4e2cbb8e3071b3ed1e6a0c7f97bc3aeab7a4
openshift v4.0.0-0.52.0

How reproducible:
Always

Steps to Reproduce:
1.Create 'example' Deployment Config using the example YAML in Deployment Configs page
2.Create 'example' Deployment using the example YAML in Deployments page
3.When all pods are created and running, go to Home -> Overview, it shows 3 of 3
4.Clicking on 3 of 3 for Deployment Config 'example'
5.Clicking on 3 of 3 for Deployment 'example'

Actual results:
4. Redirect to deploymentconfigs/example/pods page, but it shows 6 pods
5. Redirect to deployments/example/pods page, but it shows 6 pods also

Expected results:
4. It should go to replicationcontrollers/example-1/pods to show only 3 pods
5. It should go to replicasets/example-59d86d4b75/pods to show only 3 pods

Additional info:

Comment 1 Samuel Padgett 2018-11-17 14:39:04 UTC
We use label selectors in the query to create the pod list. Since the examples use the same label selector, it will match additional pods. We can fix by filtering the result using owner references, although we have to do this on the client.

Comment 2 Yadan Pei 2018-11-19 01:45:24 UTC
Yes, that's what I'm thinking about: if we can change the filter

Comment 3 Samuel Padgett 2018-12-10 16:48:01 UTC
I agree we should go to the replica set or replication controller page, not the deployment. Jon, can you take a look?

Comment 4 Jon Jackson 2018-12-11 17:41:12 UTC
Fixed by https://github.com/openshift/console/pull/934

Comment 5 Jon Jackson 2018-12-18 19:25:21 UTC
https://github.com/openshift/console/pull/934

Comment 6 Yadan Pei 2018-12-21 05:31:32 UTC
Checked against
registry.svc.ci.openshift.org/openshift/origin-v4.0-2018-12-20-221917@sha256   2e5118bf01de4e2ee4285dda0e633357d7012e12c1f08066ce22c9af3d8bb312   43b646f5b084   8 hours ago     268 MB
openshift/console commit ID: 967b28133b5e43c4bdcb48b44d30f63d2cadff9e


1.Create 'example' Deployment Config using the example YAML in Deployment Configs page
2.Create 'example' Deployment using the example YAML in Deployments page
3.When all pods are created and running, go to Home -> Overview, it shows 3 of 3
4.Clicking on 3 of 3 for Deployment Config 'example', it redirects to RC page, showing 3 pods 
5.Clicking on 3 of 3 for Deployment 'example', it redirects to RS page, showing 3 pods

Move to VERIFIED

Comment 9 errata-xmlrpc 2019-06-04 10:40:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.