Bug 1649344 - Raspberry pi 3b+ wifi not functioning on fedora 29 aarch64.
Summary: Raspberry pi 3b+ wifi not functioning on fedora 29 aarch64.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 29
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker IoT
TreeView+ depends on / blocked
 
Reported: 2018-11-13 12:30 UTC by paul aiton
Modified: 2018-12-12 01:59 UTC (History)
24 users (show)

Fixed In Version: kernel-4.19.2-301.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-11-21 16:52:41 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description paul aiton 2018-11-13 12:30:27 UTC
Description of problem:  Wifi is not usable on raspberry pi 3b+ after fresh fedora 29 minimal aarch64 install, dnf update, and installation of firmware found in this guide ( https://fedoraproject.org/wiki/Architectures/ARM/Raspberry_Pi#Raspberry_Pi_3B.2B  ). I am not seeing any dmesg indication that firmware failed to load, or any other indications concerning wifi hardware.
`sudo nmcli dev ` shows lo and eth0, but no wifi device.

Version-Release number of selected component (if applicable): fedora 29 minimal aarch64


How reproducible:
Fresh install on same hardware with https://dl.fedoraproject.org/pub/fedora-secondary/releases/29/Spins/aarch64/images/Fedora-Minimal-29-1.2.aarch64.raw.xz image.


Steps to Reproduce:
1. Install aarch64 release image to raspberry pi 3b+
2. dnf update  (as of Nov 13th 2018 )
3. sudo nmcli dev

Actual results:
$ sudo nmcli dev
DEVICE  TYPE      STATE      CONNECTION 
eth0    ethernet  connected  eth0       
lo      loopback  unmanaged  --         


Expected results:  Available wifi device


Additional info:

Comment 1 paul aiton 2018-11-13 18:27:38 UTC
It looks like the module for the RPi's WiFi is brcmfmac. I did not see the module loaded, so I tried `modprobe brcmfmac ` and saw the following message logged,

Nov 13 11:12:04 pi kernel: usbcore: registered new interface driver brcmfmac
Nov 13 11:12:04 pi kernel: cfg80211: failed to load regulatory.db
Nov 13 11:12:04 pi kernel: platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
Nov 13 11:12:04 pi kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
Nov 13 11:12:04 pi kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database


but after `dnf install crda ` the "failure with error -2" no longer shows up on module load. I still have no wifi devices showing in `nmcli dev` or `iw list`

Comment 2 Peter Robinson 2018-11-17 12:46:24 UTC
So this regressed between 4.18.13 and 4.18.4

Comment 3 Michael Young 2018-11-17 12:51:30 UTC
I had this with an rpi 3B - kernel-4.18.14-300.fc29.aarch64 worked but anything later I tried didn't until kernel-4.19.2-300.fc29.aarch64 which worked again.

Comment 4 Peter Robinson 2018-11-17 13:28:00 UTC
(In reply to Michael Young from comment #3)
> I had this with an rpi 3B - kernel-4.18.14-300.fc29.aarch64 worked but
> anything later I tried didn't until kernel-4.19.2-300.fc29.aarch64 which
> worked again.

Are you sure? At least on a clean F-29 minimal GA it doesn't work with anything from 4.18.14 right through to and including 4.19.2. The reason why is because aarch64 supports DMI and I added a patch, which landed in the 4.18.14 build, to the series where we added support for device specific NVRAM files that also loads them based on DMI to allow x86 devices with similar issues with the NVMRAM file. In all my testing I must have some how missed aarch64 wifi testing at the time. This patch is there for 4.19.x in at least F-29 (not checked F-28) and it's broken there for me on both the RPi3 and the RPi3B+.

When build a kernel with that patch reverted it works on both devices. Unless you've done something like copied brcmfmac43430-sdio.raspberrypi,3-model-b.txt to brcmfmac43430-sdio.raspberrypi.rpi.txt (device dependent) or have some other custom change I don't see how it could actually work.

Comment 5 Michael Young 2018-11-17 19:41:17 UTC
(In reply to Peter Robinson from comment #4)
> (In reply to Michael Young from comment #3)
> > I had this with an rpi 3B - kernel-4.18.14-300.fc29.aarch64 worked but
> > anything later I tried didn't until kernel-4.19.2-300.fc29.aarch64 which
> > worked again.
> 
> Are you sure?
Yes but ...

kernel-4.18.14-300.fc29.aarch64 does work consistently for me. However kernel-4.19.2-300.fc29.aarch64 worked initially and at least once afterwards but wifi often fails. The only thing I have done is to get /lib/firmware/brcm/brcmfmac43430-sdio.txt from https://fedora.roving-it.com/brcmfmac43430-sdio.txt as suggested in https://fedoraproject.org/wiki/Architectures/ARM/Raspberry_Pi?rd=Raspberry_Pi#Wifi:

Comment 6 Peter Robinson 2018-11-18 09:56:04 UTC
> kernel-4.19.2-300.fc29.aarch64 worked initially and at least once afterwards
> but wifi often fails. The only thing I have done is to get
> /lib/firmware/brcm/brcmfmac43430-sdio.txt from
> https://fedora.roving-it.com/brcmfmac43430-sdio.txt as suggested in
> https://fedoraproject.org/wiki/Architectures/ARM/
> Raspberry_Pi?rd=Raspberry_Pi#Wifi:

So, in F-29 WiFi works OOTB without doing any of that, except it regressed in 4.18.14 on aarch64, which is what this bug is about.

Comment 7 Fedora Update System 2018-11-18 10:05:39 UTC
kernel-4.19.2-301.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cb49f8a11b

Comment 8 James Ettle 2018-11-18 15:32:09 UTC
Still broken with 4.19.2-301.fc29.armv7hl

Comment 9 Peter Robinson 2018-11-18 17:56:11 UTC
(In reply to James Ettle from comment #8)
> Still broken with 4.19.2-301.fc29.armv7hl

As the title states this is covering a bug for aarch64 (not armv7) so if you're issues with ARMv7 please open a new bug and outline the issues there. This bug us explicitly about aarch64

Comment 10 Michael Young 2018-11-18 20:12:43 UTC
Sorry about the earlier confusion, I hadn't realized the on-board wireless was now supposed to work out of the box. I was getting confusing results after I tried to remove the added file so I reinstalled Fedora. My new results have wifi failing with kernel-4.18.16-300.fc29.aarch64 (from the raw image I used) but working with kernel-4.19.2-301.fc29.aarch64 . This is with a raspberry pi 3B (not +) and the only modification was to copy the network configuration files in /etc/sysconfig/network-scripts from a previous install.

Comment 11 Peter Robinson 2018-11-18 20:55:54 UTC
Michael perfect, that's exactly what I expected, thanks for the confirmation.

Comment 12 Fedora Update System 2018-11-19 04:57:46 UTC
kernel-4.19.2-301.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cb49f8a11b

Comment 13 paul aiton 2018-11-19 15:16:19 UTC
I have updated to the above posted kernel, and am still not seeing the interface.

# after fresh reboot
[root@pi ~]# uname -a
Linux pi 4.19.2-301.fc29.aarch64 #1 SMP Sat Nov 17 17:46:26 UTC 2018 aarch64 aarch64 aarch64 GNU/Linux
[root@pi ~]# nmcli dev
DEVICE  TYPE      STATE      CONNECTION 
eth0    ethernet  connected  eth0       
lo      loopback  unmanaged  --         
[root@pi ~]# nmcli dev wifi list
[root@pi ~]# lsmod | egrep -i brcmfmac
[root@pi ~]# modprobe -vvv brcmfmac
modprobe: INFO: custom logging function 0xaaaabdbdc7c8 registered
insmod /lib/modules/4.19.2-301.fc29.aarch64/kernel/net/wireless/cfg80211.ko.xz 
insmod /lib/modules/4.19.2-301.fc29.aarch64/kernel/drivers/net/wireless/broadcom/brcm80211/brcmutil/brcmutil.ko.xz 
insmod /lib/modules/4.19.2-301.fc29.aarch64/kernel/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko.xz 
modprobe: INFO: context 0xaaaaed62a4d0 released
[root@pi ~]# nmcli dev 
DEVICE  TYPE      STATE      CONNECTION 
eth0    ethernet  connected  eth0       
lo      loopback  unmanaged  --         
[root@pi ~]# nmcli dev wifi list
[root@pi ~]# dmesg | tail    # removed irrelevant entries from before loading module
[  147.057191] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[  147.067195] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[  147.220131] usbcore: registered new interface driver brcmfmac
[root@pi ~]#

Comment 14 Peter Robinson 2018-11-19 15:28:19 UTC
(In reply to paul aiton from comment #13)
> I have updated to the above posted kernel, and am still not seeing the
> interface.

can you provide "dmesg|grep brcm" and "dmesg |grep -i firmware"

Also what version of linux-firmware do you have installed.

Finally what is the rating of the PSU you're running

Comment 15 paul aiton 2018-11-19 15:48:32 UTC
[root@pi ~]# dmesg | egrep brcm
[  147.220131] usbcore: registered new interface driver brcmfmac
[root@pi ~]# dmesg | grep -i firmware
[    4.396381] raspberrypi-firmware soc:firmware: Attached to firmware from 2018-09-21 15:44


PSU is 5V, 2500 mA

Comment 16 paul aiton 2018-11-19 15:49:57 UTC
linux-firmware-20181008-88.gitc6b6265d.fc29.noarch

Comment 17 Fedora Update System 2018-11-21 16:52:41 UTC
kernel-4.19.2-301.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Rich Fellinger 2018-11-24 22:40:44 UTC
I am not seeing the WiFi interface on rpi3 B+ with 4.19.3-300.  This is after a dnf system upgrade from 28 and a later dnf update.  WiFi never worked for me since the system upgrade to 29:

[root@rpi3-1 ~]# uname -a
Linux rpi3-1 4.19.3-300.fc29.aarch64 #1 SMP Wed Nov 21 15:15:38 UTC 2018 aarch64 aarch64 aarch64 GNU/Linux

Here's the same set of commands used by paul above:

[root@rpi3-1 ~]# nmcli dev
DEVICE  TYPE      STATE      CONNECTION 
eth0    ethernet  connected  eth0       
lo      loopback  unmanaged  --         
[root@rpi3-1 ~]# nmcli dev wifi list
[root@rpi3-1 ~]# lsmod | egrep -i brcmfmac
[root@rpi3-1 ~]# modprobe -vvv brcmfmac
modprobe: INFO: custom logging function 0xaaaad1fd37c8 registered
insmod /lib/modules/4.19.3-300.fc29.aarch64/kernel/net/wireless/cfg80211.ko.xz 
insmod /lib/modules/4.19.3-300.fc29.aarch64/kernel/drivers/net/wireless/broadcom/brcm80211/brcmutil/brcmutil.ko.xz 
insmod /lib/modules/4.19.3-300.fc29.aarch64/kernel/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko.xz 
modprobe: INFO: context 0xaaaad94074c0 released
[root@rpi3-1 ~]# nmcli dev
DEVICE  TYPE      STATE      CONNECTION 
eth0    ethernet  connected  eth0       
lo      loopback  unmanaged  --         
[root@rpi3-1 ~]# nmcli dev wifi list

Some dmesg output:

[root@rpi3-1 ~]# dmesg|grep brcm
[   30.193520] bluetooth hci0: Direct firmware load for brcm/BCM43430A1.hcd failed with error -2
[   30.213535] Bluetooth: hci0: BCM: Patch brcm/BCM43430A1.hcd not found
[  100.172171] usbcore: registered new interface driver brcmfmac
[root@rpi3-1 ~]# dmesg |grep -i firmware
[    4.776110] raspberrypi-firmware soc:firmware: Attached to firmware from 2018-09-21 15:44
[   30.193520] bluetooth hci0: Direct firmware load for brcm/BCM43430A1.hcd failed with error -2
[  100.028101] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2

firmware:

Installed Packages
Name         : linux-firmware
Version      : 20181008
Release      : 88.gitc6b6265d.fc29
Arch         : noarch
Size         : 291 M
Source       : linux-firmware-20181008-88.gitc6b6265d.fc29.src.rpm
Repo         : @System
From repo    : updates
Summary      : Firmware files used by the Linux kernel
URL          : http://www.kernel.org/
License      : GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
Description  : This package includes firmware files required for some devices to
             : operate.


PSU is 5v 2.5A

Comment 19 Peter Robinson 2018-11-25 09:02:43 UTC
(In reply to Rich Fellinger from comment #18)
> I am not seeing the WiFi interface on rpi3 B+ with 4.19.3-300.  This is
> after a dnf system upgrade from 28 and a later dnf update.  WiFi never
> worked for me since the system upgrade to 29:

That's a different bug, it's being handled in rhbz 1652093

Comment 20 Armin Wies 2018-11-25 20:34:20 UTC
Hi Peter,

(In reply to Peter Robinson from comment #19)
> (In reply to Rich Fellinger from comment #18)
> > I am not seeing the WiFi interface on rpi3 B+ with 4.19.3-300.  This is
> > after a dnf system upgrade from 28 and a later dnf update.  WiFi never
> > worked for me since the system upgrade to 29:
> 
> That's a different bug, it's being handled in rhbz 1652093

I actually do have the same problem with kernel-4.19.3-300.fc29.aarch64 on a fresh Fedora 29 installation.

Today I did a fresh installation from Fedora-Minimal-29-1.2.aarch64.raw.xz.
The kernel that comes with the image is kernel-modules-4.18.16-300.fc29.aarch64.
(no WIFI available)
When you upgrade, you will get 4.19.3-300... which is not working for me neither (on raspi 3B+)...

On friday (2018-11-23) I did the same and after the upgrade everything was working fine for me. It seems that I somehow received kernel-4.19.2-301.fc29,  though 4.19.3-300 seems to be out since 2018-11-21...

No idea.. but can somebody confirm that 4.19.3-300 is working on a Pi 3B+ ?

Thank you!

Comment 21 Peter Robinson 2018-11-25 20:44:01 UTC
(In reply to Armin Wies from comment #20)
> Hi Peter,
> 
> (In reply to Peter Robinson from comment #19)
> > (In reply to Rich Fellinger from comment #18)
> > > I am not seeing the WiFi interface on rpi3 B+ with 4.19.3-300.  This is
> > > after a dnf system upgrade from 28 and a later dnf update.  WiFi never
> > > worked for me since the system upgrade to 29:
> > 
> > That's a different bug, it's being handled in rhbz 1652093
> 
> I actually do have the same problem with kernel-4.19.3-300.fc29.aarch64 on a
> fresh Fedora 29 installation.

So please comment on the correct bug, this particular bug is now fixed. This will be my last comment on this bug

Comment 22 paul aiton 2018-11-26 18:14:22 UTC
This issue has not been fixed for me. I am still having the same issue as originally reported. I am currently on 4.19.3-300.fc29.aarch64

Comment 23 Nikolaos Perrakis 2018-12-10 22:37:56 UTC
I am having the same problem. It is unresolved with today's latest updates. WiFi is not working on an aarch64 F29 server image on a rpi3b+:

Some command line information to help:

# nmcli dev
DEVICE  TYPE      STATE      CONNECTION 
eth0    ethernet  connected  eth0       
lo      loopback  unmanaged  --         
# uname -a
Linux raspberry1 4.19.6-300.fc29.aarch64 #1 SMP Sun Dec 2 17:21:47 UTC 2018 aarch64 aarch64 aarch64 GNU/Linux
# nmcli dev
DEVICE  TYPE      STATE      CONNECTION 
eth0    ethernet  connected  eth0       
lo      loopback  unmanaged  --         
# nmcli dev wifi list
# lsmod | egrep -i brcmfmac
# modprobe -vvv brcmfmac
modprobe: INFO: custom logging function 0xaaaadec527c8 registered
insmod /lib/modules/4.19.6-300.fc29.aarch64/kernel/net/wireless/cfg80211.ko.xz 
insmod /lib/modules/4.19.6-300.fc29.aarch64/kernel/drivers/net/wireless/broadcom/brcm80211/brcmutil/brcmutil.ko.xz 
insmod /lib/modules/4.19.6-300.fc29.aarch64/kernel/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko.xz 
modprobe: INFO: context 0xaaaae2b044b0 released
# nmcli dev
DEVICE  TYPE      STATE      CONNECTION 
eth0    ethernet  connected  eth0       
lo      loopback  unmanaged  --         
# dmesg|grep brcm
[   21.592497] bluetooth hci0: Direct firmware load for brcm/BCM4345C0.hcd failed with error -2
[   21.601113] Bluetooth: hci0: BCM: Patch brcm/BCM4345C0.hcd not found
[  971.285600] usbcore: registered new interface driver brcmfmac
# dmesg|grep -i firmware
[    4.807984] raspberrypi-firmware soc:firmware: Attached to firmware from 2018-11-04 16:32
[   21.592497] bluetooth hci0: Direct firmware load for brcm/BCM4345C0.hcd failed with error -2
# dnf info linux-firmware
Installed Packages
Name         : linux-firmware
Version      : 20181008
Release      : 88.gitc6b6265d.fc29
Arch         : noarch
Size         : 291 M
Source       : linux-firmware-20181008-88.gitc6b6265d.fc29.src.rpm
Repo         : @System
From repo    : updates
Summary      : Firmware files used by the Linux kernel
URL          : http://www.kernel.org/
License      : GPL+ and GPLv2+ and MIT and Redistributable, no modification permitted
Description  : This package includes firmware files required for some devices to
             : operate.

# cat /proc/cpuinfo 
processor	: 0
BogoMIPS	: 38.40
Features	: fp asimd evtstrm crc32 cpuid
CPU implementer	: 0x41
CPU architecture: 8
CPU variant	: 0x0
CPU part	: 0xd03
CPU revision	: 4

processor	: 1
BogoMIPS	: 38.40
Features	: fp asimd evtstrm crc32 cpuid
CPU implementer	: 0x41
CPU architecture: 8
CPU variant	: 0x0
CPU part	: 0xd03
CPU revision	: 4

processor	: 2
BogoMIPS	: 38.40
Features	: fp asimd evtstrm crc32 cpuid
CPU implementer	: 0x41
CPU architecture: 8
CPU variant	: 0x0
CPU part	: 0xd03
CPU revision	: 4

processor	: 3
BogoMIPS	: 38.40
Features	: fp asimd evtstrm crc32 cpuid
CPU implementer	: 0x41
CPU architecture: 8
CPU variant	: 0x0
CPU part	: 0xd03
CPU revision	: 4

# ls -la /lib/firmware/brcm/
total 15500
drwxr-xr-x.  2 root root   4096 Nov  8 20:20 .
drwxr-xr-x. 81 root root  12288 Nov  8 20:21 ..
-rw-r--r--.  1 root root  54734 Oct 13 16:50 BCM-0bb4-0306.hcd
-rw-r--r--.  1 root root 269595 Oct 13 16:50 bcm4329-fullmac-4.bin
-rw-r--r--.  1 root root  96224 Oct 13 16:50 bcm43xx-0.fw
-rw-r--r--.  1 root root    180 Oct 13 16:50 bcm43xx_hdr-0.fw
-rw-r--r--.  1 root root 397312 Oct 13 16:50 brcmfmac43143.bin
-rw-r--r--.  1 root root 385067 Oct 13 16:50 brcmfmac43143-sdio.bin
-rw-r--r--.  1 root root 348160 Oct 13 16:50 brcmfmac43236b.bin
-rw-r--r--.  1 root root 455745 Oct 13 16:50 brcmfmac43241b0-sdio.bin
-rw-r--r--.  1 root root 403855 Oct 13 16:50 brcmfmac43241b4-sdio.bin
-rw-r--r--.  1 root root 408682 Oct 13 16:50 brcmfmac43241b5-sdio.bin
-rw-r--r--.  1 root root 479232 Oct 13 16:50 brcmfmac43242a.bin
-rw-r--r--.  1 root root 253748 Oct 13 16:50 brcmfmac4329-sdio.bin
-rw-r--r--.  1 root root 222126 Oct 13 16:50 brcmfmac4330-sdio.bin
-rw-r--r--.  1 root root 400864 Oct 13 16:50 brcmfmac43340-sdio.bin
-rw-r--r--.  1 root root 451566 Oct 13 16:50 brcmfmac4334-sdio.bin
-rw-r--r--.  1 root root 569291 Oct 13 16:50 brcmfmac4335-sdio.bin
-rw-r--r--.  1 root root 202107 Oct 13 16:50 brcmfmac43362-sdio.bin
-rw-r--r--.  1 root root 562183 Oct 13 16:50 brcmfmac4339-sdio.bin
-rw-r--r--.  1 root root 382455 Oct 13 16:50 brcmfmac43430a0-sdio.bin
-rw-r--r--.  1 root root    875 Oct 13 16:50 brcmfmac43430-sdio.AP6212.txt
-rw-r--r--.  1 root root 388739 Oct 13 16:50 brcmfmac43430-sdio.bin
-rw-r--r--.  1 root root    831 Oct 13 16:50 brcmfmac43430-sdio.MUR1DX.txt
-rw-r--r--.  1 root root    625 Oct 13 16:50 brcmfmac43430-sdio.raspberrypi,3-model-b.txt
-rw-r--r--.  1 root root 488193 Oct 13 16:50 brcmfmac43455-sdio.bin
-rw-r--r--.  1 root root   1687 Oct 13 16:50 brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt
-rw-r--r--.  1 root root 623304 Oct 13 16:50 brcmfmac4350c2-pcie.bin
-rw-r--r--.  1 root root 626140 Oct 13 16:50 brcmfmac4350-pcie.bin
-rw-r--r--.  1 root root 605388 Oct 13 16:50 brcmfmac4354-sdio.bin
-rw-r--r--.  1 root root 557056 Oct 13 16:50 brcmfmac43569.bin
-rw-r--r--.  1 root root 648770 Oct 13 16:50 brcmfmac4356-pcie.bin
-rw-r--r--.  1 root root 526383 Oct 13 16:50 brcmfmac4356-sdio.bin
-rw-r--r--.  1 root root 550333 Oct 13 16:50 brcmfmac43570-pcie.bin
-rw-r--r--.  1 root root 633817 Oct 13 16:50 brcmfmac4358-pcie.bin
-rw-r--r--.  1 root root 595472 Oct 13 16:50 brcmfmac43602-pcie.ap.bin
-rw-r--r--.  1 root root 635449 Oct 13 16:50 brcmfmac43602-pcie.bin
-rw-r--r--.  1 root root 989401 Oct 13 16:50 brcmfmac4366b-pcie.bin
-rw-r--r--.  1 root root 623448 Oct 13 16:50 brcmfmac4371-pcie.bin
-rw-r--r--.  1 root root 479232 Oct 13 16:50 brcmfmac4373.bin
-rw-r--r--.  1 root root 457994 Oct 13 16:50 brcmfmac4373-sdio.bin

Comment 24 Peter Robinson 2018-12-12 01:59:48 UTC
(In reply to Nikolaos Perrakis from comment #23)
> I am having the same problem. It is unresolved with today's latest updates.
> WiFi is not working on an aarch64 F29 server image on a rpi3b+:

As commented above this is not the same issue, I believe the issue you are seeing is covered in this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1652093


Note You need to log in before you can comment on or make changes to this bug.