Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1649527 - Incorrect entities displayed in service dialog tag control options modal
Summary: Incorrect entities displayed in service dialog tag control options modal
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: GA
: 5.10.0
Assignee: Martin Povolny
QA Contact: Shveta
Red Hat CloudForms Documentation
URL:
Whiteboard: testathon:ui:service;dialog
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-13 19:30 UTC by Mike Shriver
Modified: 2020-06-30 18:22 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-12 16:52:59 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Mike Shriver 2018-11-13 19:30:56 UTC
Description of problem:
The modal for the tag control widget on a service dialog displays the wrong entities list for the selected catalog


Version-Release number of selected component (if applicable):
5.10.0.22.20181030184024_26956a0

How reproducible:
100%

Steps to Reproduce:
1. Create new service dialog, or edit existing
2. Include tag control widget in the form
3. View tag control options
4. On resulting modal, go to 'Options' tab
5. Note entities list is already populated with locations
6. select 'Location' for category
7. Note workloads are listed in entities

Actual results:
The entities list on the modal displays the _next_ category in the list instead of the currently selected one

Expected results:
The relevant entities for the selected catalog are displayed

Additional info:

Comment 5 drew uhlmann 2018-12-07 20:03:29 UTC
Looks like a UI issue to me, there's a JS console error present.

Comment 8 CFME Bot 2018-12-12 15:14:14 UTC
New commit detected on ManageIQ/ui-components/master:

https://github.com/ManageIQ/ui-components/commit/9722cdf1163be1e36dd5a550bc020cc1433ea521
commit 9722cdf1163be1e36dd5a550bc020cc1433ea521
Author:     Martin Povolny <mpovolny@redhat.com>
AuthorDate: Wed Dec 12 09:02:56 2018 -0500
Commit:     Martin Povolny <mpovolny@redhat.com>
CommitDate: Wed Dec 12 09:02:56 2018 -0500

    Fix lodash "find" call in currentCategoryEntries.

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1649527

 src/dialog-editor/components/modal/modalComponent.ts | 5 +-
 1 file changed, 3 insertions(+), 2 deletions(-)

Comment 10 CFME Bot 2018-12-13 14:54:37 UTC
New commit detected on ManageIQ/ui-components/hammer:

https://github.com/ManageIQ/ui-components/commit/d312e4e7fb58f40c76b4b018e7591148829fa2a9
commit d312e4e7fb58f40c76b4b018e7591148829fa2a9
Author:     Martin Hradil <himdel@seznam.cz>
AuthorDate: Wed Dec 12 10:08:31 2018 -0500
Commit:     Martin Hradil <himdel@seznam.cz>
CommitDate: Wed Dec 12 10:08:31 2018 -0500

    Merge pull request #358 from ManageIQ/fix_tag_control_entries

    Fix lodash "find" call in currentCategoryEntries.

    (cherry picked from commit 0ab3d77f20f18ee14d621e09090342dbbc3d671d)

    https://bugzilla.redhat.com/show_bug.cgi?id=1649527

 src/dialog-editor/components/modal/modalComponent.ts | 5 +-
 1 file changed, 3 insertions(+), 2 deletions(-)

Comment 13 Mike Shriver 2019-01-09 23:26:21 UTC
Tested in CFME 5.10.0.31.20190108221820_a0968c8

The service dialog tag control modal now lists the correct entities for the selected category


Note You need to log in before you can comment on or make changes to this bug.