Bug 164955 - nmbd not functioning -- seems not to respond to netbios requests
nmbd not functioning -- seems not to respond to netbios requests
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 21:34 EDT by J. William Cupp
Modified: 2014-08-31 19:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-22 11:59:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. William Cupp 2005-08-02 21:34:40 EDT
From Bugzilla Helper:
User-Agent: Opera/8.02 (X11; Linux i686; U; en)

Description of problem:
Cannot link Windows XP professional and Linux box on home wireless network since 
upgrading to FC4.  Everything worked fine prior to upgrade.  After 
troubleshooting using Google-supplied guidance, have determined network is 
working (pings both ways), smb seems configured correctly and all desired 
services are offered, Service Configuration (GUI screen) reports smb is 
configured to start at boot, and reports both daemons smbd and nmbd are running.

However, Linux reports network consists of "Windows Network" with no stations 
signing in to the network.  Windows box acts as if there is no Windows Network 
Neighborhood to connect into.  In one troubleshooting page (http://www.rtr.com/
win95pak/sambadiag.htm) the first step of guided troubleshooting that fails 
relates to nmbd not being installed or not being configured correctly.  However, 
this (old) guidance relates to v1.9.13 and I'm using v.3.0.14 ... so the step 
"issue the command 'nmbd -L ...' is no longer applicable.  After reading the man 
page, I'm still not clear on how to replicate this step under v.3 ....

As best I can relate, this problem is quite similar to the one I found reported 
under Bug 150582 "nmbd dies when windows client requests browse list" (March 
2005) but the nmbd daemon isn't dying (I think), it's just sitting silently and 
failing to respond.  In the mentioned troubleshooting guide, I have already 
performed the steps to confirm nmbd is listening on UDP port 137, so I don't 
think that's the problem.

If guided, I can probably find and submit relevant log files, etc.  Please tell 
me where to look.

At present, since my home network runs from the Linux machine, I have no network 
services from my Windows clients' points of view.

Version-Release number of selected component (if applicable):
Version 3.0.14a-2 

How reproducible:
Always

Steps to Reproduce:
1. Boot up Linux FC 4 (or, nmbd Version 3.0.14a-2)
2. Attempt to connect to network with Windows machine
  

Additional info:
Comment 1 Christian Iseli 2007-01-22 06:44:59 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 2 J. William Cupp 2007-01-22 11:59:05 EST
I have upgraded to Fedora Core 5 and no longer have the problem.

Note You need to log in before you can comment on or make changes to this bug.