Bug 1649630 - tcmu-runner/dyn-logger: DEBUG SCSI CMD loglevel is not working in the container which has no syslogd service installed
Summary: tcmu-runner/dyn-logger: DEBUG SCSI CMD loglevel is not working in the contain...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tcmu-runner
Version: ocs-3.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: OCS 3.11.1
Assignee: Prasanna Kumar Kalever
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks: OCS-3.11.1-devel-triage-done 1644160
TreeView+ depends on / blocked
 
Reported: 2018-11-14 06:07 UTC by Xiubo Li
Modified: 2019-02-11 08:40 UTC (History)
11 users (show)

Fixed In Version: tcmu-runner-1.2.0-28.el7rhgs
Doc Type: Bug Fix
Doc Text:
Previously, the DEBUG_SCSI command logs from tcmu-runner daemon were dumped to stdout, which were expected to be recorded by the syslog buffer. Currently, this is not working as expected as most containers are not running syslogd service. With this fix, the DEBUG_SCSI command logs are pushed through syslog system call. Hence, the container host node will record the logs in the absence of syslogd service inside the container.
Clone Of:
Environment:
Last Closed: 2019-02-07 03:38:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0285 None None None 2019-02-07 03:38:33 UTC

Description Xiubo Li 2018-11-14 06:07:32 UTC
Description of problem:

Currently the DEBUG SCSI CMD loglevel logs are all outputed to the stdout file, which will record to the syslogd buffer, but mostly the container pod won't install the syslogd service, so will miss the DEBUG SCSI CMD logs here.

Why we didn't record this logs to tcmu-runner.log file was because this logs will burst and quickly run out of the disk space if running for a long time without the logrotate support.

In the upstream the log rotate feature has been supported and change it back to tcmu-runner.log.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Prasanna Kumar Kalever 2018-11-14 06:17:36 UTC
PR: https://github.com/open-iscsi/tcmu-runner/pull/480

Comment 13 errata-xmlrpc 2019-02-07 03:38:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0285


Note You need to log in before you can comment on or make changes to this bug.