Bug 164965 - File conflict in kdelibs and kde-i18n-Polish rpm package
File conflict in kdelibs and kde-i18n-Polish rpm package
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 00:50 EDT by Ed Solis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 05:28:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed Solis 2005-08-03 00:50:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
Installing kde rpm pacakge (3.4.2-0.fc4.1) fails because of file conflicts in the kdelibs and kde-i18n-Polish package.

It seems that the kde package also includes the polish documentation.

It's the files under /usr/share/doc/HTML/pl/common/* that are in conflict.

Version-Release number of selected component (if applicable):
kdelibs-3.4.2-0.fc4.1

How reproducible:
Always

Steps to Reproduce:
1. Install the kde pacakges (3.4.2-0.fc4.1)
2.
3.
  

Actual Results:  The kde installation should have succeeded.

Expected Results:  Installation fails with file conflicts.

Additional info:
Comment 1 Ngo Than 2005-08-03 04:47:44 EDT
strange, i'm not able to reproduce this problem here!
i have updated to KDE-3.4.2 without any file conflicts. And only kde-i18n-Polish
is the owner of all files under /usr/share/doc/HTML/pl/common/*

Which KDE version did you have before update? Could you please give the list
of your kde packages (name-version-release) before update? Thanks

please try following steps and look if this problem appears.

- remove your old kde-i18n-Polish with rpm -e kde-i18n-Polish

- install your old kde-i18n-Polish again with rpm -ivh
  kde-i18n-Polish-3.4.1-0.fc4.1.noarch.rpm

- update to new kde-i18n-Polish with
  rpm -Uvh kde-i18n-Polish-3.4.2-0.fc4.1.noarch.rpm

Comment 2 Ed Solis 2005-08-03 19:09:46 EDT
Here's the list of the KDE package before update. 

kdeaccessibility-3.4.0-1
kdeaddons-3.4.0-2
kdeadmin-3.4.0-1
kdeartwork-3.4.0-1
kdeartwork-icons-3.4.0-1
kdebase-3.4.0-5
kdebase-devel-3.4.0-5
kdebindings-3.4.0-1
kdebindings-devel-3.4.0-1
kdegraphics-3.4.0-2
kdegraphics-devel-3.4.0-2
kde-i18n-Bengali-3.4.0-1
kde-i18n-Brazil-3.4.0-1
kde-i18n-British-3.4.0-1
kde-i18n-Bulgarian-3.4.0-1
kde-i18n-Catalan-3.4.0-1
kde-i18n-Chinese-3.4.0-1
kde-i18n-Chinese-Big5-3.4.0-1
kde-i18n-Czech-3.4.0-1
kde-i18n-Danish-3.4.0-1
kde-i18n-Dutch-3.4.0-1
kde-i18n-Estonian-3.4.0-1
kde-i18n-Finnish-3.4.0-1
kde-i18n-French-3.4.0-1
kde-i18n-German-3.4.0-1
kde-i18n-Greek-3.4.0-1
kde-i18n-Hebrew-3.4.0-1
kde-i18n-Hindi-3.4.0-1
kde-i18n-Hungarian-3.4.0-1
kde-i18n-Icelandic-3.4.0-1
kde-i18n-Italian-3.4.0-1
kde-i18n-Japanese-3.4.0-1
kde-i18n-Norwegian-3.4.0-1
kde-i18n-Norwegian-Nynorsk-3.4.0-1
kde-i18n-Polish-3.4.0-1
kde-i18n-Portuguese-3.4.0-1
kde-i18n-Punjabi-3.4.0-1
kde-i18n-Romanian-3.4.0-1
kde-i18n-Russian-3.4.0-1
kde-i18n-Serbian-3.4.0-1
kde-i18n-Slovak-3.4.0-1
kde-i18n-Slovenian-3.4.0-1
kde-i18n-Spanish-3.4.0-1
kde-i18n-Swedish-3.4.0-1
kde-i18n-Tamil-3.4.0-1
kde-i18n-Turkish-3.4.0-1
kde-i18n-Ukrainian-3.4.0-1
kdelibs-3.4.0-6
kdelibs-devel-3.4.0-6
kdemultimedia-3.4.0-2
kdemultimedia-devel-3.4.0-2
kdenetwork-3.4.0-3
kdenetwork-devel-3.4.0-3
kdepim-3.4.0-4
kdepim-devel-3.4.0-4
kdesdk-3.4.0-3
kdesdk-devel-3.4.0-3
kdeutils-3.4.0-1
kdeutils-devel-3.4.0-1
kdevelop-3.2.0-2
kdewebdev-3.4.0-3
kdewebdev-devel-3.4.0-3
Comment 3 Ed Solis 2005-08-03 19:16:20 EDT
I will have to get back to you with the results of the re-installation of the
original kde-i18n-Polish package. BTW, the original Polish package is version
3.4.0-1 and not 3.4.1
Comment 4 Ed Solis 2005-08-03 20:14:57 EDT
I have tried the step that you have mentioned but the result is still the same.
I'm attempting to update my KDE installation as follows:

# rpm -Uvh kde*3.4.2*.rpm

and the result is...

        file /usr/share/doc/HTML/pl/common/1.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/10.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/2.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/3.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/4.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/5.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/6.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/7.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/8.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/9.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/appheader.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/artistic-license.html conflicts
between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and
kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/bottom-left.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/bottom-middle.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/bottom-right.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/bottom1.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/bottom2.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/bsd-license.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/docheadergears.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/doctop1.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/doctop1a.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/doctop1b.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/doctop2.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/doxygen.css conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/fdl-license conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/fdl-license.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/footer.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/gpl-license conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/gpl-license.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/grad.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/header.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/headerbg.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/kde-common.css conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/kde-default.css conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/kde-localised.css.template conflicts
between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and
kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/kde-web.css conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/kde_logo.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/kde_logo_bg.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/kmenu.png conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/lgpl-license conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/lgpl-license.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/mainfooter.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/mainheader.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/qpl-license.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/shadow.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/top-left.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/top-middle.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/top-right-konqueror.png conflicts
between attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and
kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/web-docbottom.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/web-doctop.png conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/x11-license.html conflicts between
attempted installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1
        file /usr/share/doc/HTML/pl/common/xml.dcl conflicts between attempted
installs of kde-i18n-Polish-3.4.2-0.fc4.1 and kdelibs-3.4.2-0.fc4.1

I have also tried updating using as follows:

# yum -y update

but the results are the same.

yum version yum-2.3.2-7
rpm version rpm-4.4.1-22
Comment 5 Ed Solis 2005-08-03 20:41:12 EDT
More info...

Just to be clear, I'm try to update from KDE 3.4.0 (original FC4 version) to KDE
3.4.2.

In the KDE 3.4.0 set of packages, the /usr/share/doc/HTML/pl/common directory is
owned by the kde-i18n-Polish package but the contents of
/usr/share/doc/HTML/pl/common are owned by the kdelibs package.

In the KDE 3.4.2 set of pacakge (base on rpm listing), the
/usr/share/doc/HTML/pl/common directory and its contents are now owned by
kde-i18n-Polish package.

In the KDE 3.4.1 set of package (base on rpm listing), the
/usr/share/doc/HTML/pl directory does not even exists in any of the KDE package.

Could it be that if the upgrade is 3.4.0 -> 3.4.2 some sort of file conflict
would result because of the differnt package owners of the content under
/usr/share/doc/HTML/pl/common but if the upgrade path is 3.4.0 -> 3.4.1 ->
3.4.2, this problem will not manifest since the 3.4.0 -> 3.4.1 upgrade will
remove the /usr/share/doc/HTML/pl (does not exist in 3.4.1) and the 3.4.1 ->
3.4.2 will succeed since there are not /usr/share/doc/HTML/pl/common files that
can cause any conflict with the new 3.4.2 package owner of the files under
/usr/share/doc/HTML/pl/common?

Comment 6 Ed Solis 2005-08-04 01:10:59 EDT
Just tried the following upgrade path:

   KDE 3.4.0 -> 3.4.1 -> 3.4.2

and the upgrade was successful.

There might be some other much simplier work around than doing a full upgrade to
3.4.1 then another full upgrade to 3.4.2.

The only drawback I see is that the KDE pacakge is around 395 MB in size
(complete with all the i18n). Following this work around would require nearly
800 MB of download.
Comment 7 Ed Solis 2005-08-04 03:21:38 EDT
Haven't tested this other work around but it might work.

Update path: 3.4.0 -> 3.4.2

1. rpm -e kde-i18n-Polish-3.4.0-1
2. Install KDE 3.4.2 (excluding kde-i18n-Polish package)
3. rpm -Uvh kde-i18n-Polish-3.4.2-0.fc4.1

Comment 8 Ngo Than 2005-08-04 05:28:40 EDT
i have taken a look at kdelibs-3.4.0-6, it does not contain the directory
/usr/share/doc/HTML/pl

and i can update from 3.4.0 to 3.4.2 without any problem! i don't think it's
a bug in KDE package. It could be that your rpm database is broken.

Note You need to log in before you can comment on or make changes to this bug.