Bug 1649703 - Simultaneous manifest upload by two users fails
Summary: Simultaneous manifest upload by two users fails
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Barnaby Court
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 09:33 UTC by Stephen Wadeley
Modified: 2020-01-15 20:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-15 20:30:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stephen Wadeley 2018-11-14 09:33:46 UTC
Description of problem:

Two users cannot load manifests at the same time and no indication is given to the second user that another user is loading a manifest.


Version-Release number of selected component (if applicable):

tfm-rubygem-katello-3.9.0-0.1.rc2.el7sat.noarch

How reproducible:
tested twice

Steps to Reproduce:
1.  In Browser1:
1.1 Create two orgs, "ABC" and "123"
1.2 Create a second user with all perms, locations, and orgs.
1.3 Switch to org ABC

2.  In Browser2:
2.1 Log in and switch to org 123

3.  In Browser1 as org ABC::
3.1 Content > Subscriptions > Manage Manifest
3.2 Upload Manifest; observe the expected status bar UI 

5.   In Browser2 as org 123:
5.1  Content > Subscriptions > Manage Manifest
4.2  Upload Manifest; observe the expected status bar UI
6.  

Actual results:

In Browser2, status bar UI is blank and never changes.

Expected results:

Upload works as expected or a warning is displayed to try again later.

Additional info:

This bug is a side effect of resolving this bug:

Bug 1596885 - Manifest upload UI status bleeds into other orgs

Comment 2 Brad Buckingham 2018-12-07 14:00:47 UTC
Hi Stephen,

Can you attach a foreman_debug for this one?
If not, are there any errors in either the tasks, production.log or other logs that can be shared?

Thanks!

Comment 3 Brad Buckingham 2018-12-07 14:01:29 UTC
Also, do you happen to know if this is a regression from 6.3?

Comment 4 Stephen Wadeley 2018-12-07 14:41:27 UTC
Hello Brad

No logs, sorry. I will have to test that again on both Sat6.3, Sat6.4, and Sat6.5 to get logs and to see if its a regression. 

I will leave the needinfo set on me till then.

Thank you

Comment 5 Stephen Wadeley 2018-12-10 10:41:34 UTC
Hello Brad

Testing in Sat6.4
[root@rhel7-5-sat6-4 ~]# rpm -q tfm-rubygem-katello
tfm-rubygem-katello-3.7.0.41-1.el7sat.noarch


I notice in comment 0 I neglected to mention the Admin check box.

Just tried to reproduce this in Sat6.4, and selected that Admin check box.

I saw warning popup message, clicked through to see task and saw:

This subscription management application has already been imported by another owner. (I see this in both browsers).

I notice in browser 2, despite selecting 123 as the org, the task page says "TasksImport Manifest organization 'ABC'"

Perhaps that's because I selected the "Admin" check box. I will try again without that option selected.

------------------

Removed "Admin" rights from user "OtherAdmin". In Browser 2, logged out and in again, Org 123 is selected.

In browser 1, Org ABC is selected.

Import manifest in both browsers. In browser 1 as user "Admin", I see popup warning "Task Import Manifest completed with a result of warning" then another popup to say its completed. 

In browser 2 as user "OtherAdmin" the task completes as expected.

In both cases, progress bar displays as expected.

In Browser 1 as user "admin" I click on the warning popup to see the task. Error is: This subscription management application has already been imported by another owner.

That is strange given the second popup indicated the task was OK. Monitor > Tasks shows just that one task, the failed task. This suggests the popup about successful completion were intended for the other user in the other org.


In browser 2 as user "OtherAdmin" in Org 123:
Tasks >> Import Manifest organization '123'
Name: Import Manifest organization '123'
Result:  success


Thank you

Comment 13 Bryan Kearney 2019-12-03 16:34:47 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 18 Bryan Kearney 2020-01-15 20:30:34 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.