Bug 1649717 - Insights-client remove.conf doesn't support regexp pattern occurrences of the preceding {x,y}, due to current architecture solution
Summary: Insights-client remove.conf doesn't support regexp pattern occurrences of the...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Hybrid Cloud Console (console.redhat.com)
Classification: Red Hat
Component: Client
Version: unspecified
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: jcrafts
QA Contact: Pavol Kotvan
Kevin Blake
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 10:52 UTC by Eduard
Modified: 2019-11-20 14:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-15 12:08:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eduard 2018-11-14 10:52:39 UTC
Description of problem:

insights-client doesn't support {x,y} regexp pattern, due to current architecture solution, due to using in remove.conf the comma separator in patterns section. 


How reproducible: 100% 


Steps to Reproduce:
# cat /etc/insights-client/remove.conf
[remove]
patterns=[[:digit:]]\{1,3\}

#insights-client --no-upload

Actual results:

grep: Unmatched \{
grep: Unmatched \{
grep: Unmatched \{
grep: Unmatched \{
grep: Unmatched \{
grep: Unmatched \{
grep: Unmatched \{
grep: Unmatched \{
grep: Unmatched \{
grep: Unmatched \{
grep: Unmatched \{
...
Additional info:


Note You need to log in before you can comment on or make changes to this bug.