Bug 1649720 - Unlimited setting for filter does not get rendered in the UI
Summary: Unlimited setting for filter does not get rendered in the UI
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Radovan Drazny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 11:00 UTC by Peter Ondrejka
Modified: 2019-11-21 09:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-21 09:33:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Peter Ondrejka 2018-11-14 11:00:21 UTC
Description of problem:
Setting a filter to Unlimited completes successfully in the UI but afterwards the setting is not marked in the filters table and when revisiting the filter details the Unlimited checkbox is unchecked. 

Version-Release number of selected component (if applicable):
Sat 6.5 snap 8

How reproducible:
always

Steps to Reproduce:
1. create a custom role
2. add filter, set resource type and permission. If Unlimited is checked by default, uncheck it manually, then check it again.
3. Submit

Actual results:
The role's filters table shows Unlimited as unchecked, when editing the filter the checkbox is unchecked.


Additional info:
Does not apply to the Override checkbox

Comment 2 Marek Hulan 2018-11-14 12:41:56 UTC
Is the role or filter assigned to some organization/location? Is this a 6.5 regression?

Comment 3 Peter Ondrejka 2019-01-28 10:29:41 UTC
Checked again on 6.5 snap 13. It is reproducible only if role is assigned to one or more organizations, location setting does not have an effect. Looking at 6.4 Satellite I can reproduce the same problem.

Comment 4 Marek Hulan 2019-11-21 09:33:21 UTC
This is expected behavior, per the inline help:

"If the unlimited field is enabled, the filter applies to all resources of the selected type. If the unlimited field is disabled, you can specify further filtering using Foreman search syntax in the search field.> If the role is associated with organizations or locations, the filters are not considered unlimited as they are scoped accordingly."

The most important here to notice here, if filter are associated with some org/log, they are limited. The experience has changed  over last few versions a bit, since we encourage people to assign org/locs to the role. So there may be another RFE that will rename that checkbox or change the logic in showing the checkmark, but I'm closing this as NOTABUG. Please reopen if I missed something.


Note You need to log in before you can comment on or make changes to this bug.