Bug 1649727 - Some pods in running state but not accessible via rsh or exec
Summary: Some pods in running state but not accessible via rsh or exec
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.11.z
Assignee: Robert Krawitz
QA Contact: Weinan Liu
URL:
Whiteboard:
: 1649728 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 11:44 UTC by Madhusudan Upadhyay
Modified: 2018-12-14 14:39 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-14 14:39:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Madhusudan Upadhyay 2018-11-14 11:44:54 UTC
Description of problem:

- Cannot rsh the pod with the following error:

[root@customer ~]# oc rsh <pod_name>
error: unable to upgrade connection: error dialing backend: dial tcp 127.0.0.1:xxxxx: connect: cannot assign requested address

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

- error: unable to upgrade connection: error dialing backend: dial tcp 127.0.0.1:xxxxx: connect: cannot assign requested address


Expected results:

- Successful rsh into the pod


Additional info:

- The bug is being tracked in kubernetes 1.11:
  [+] https://github.com/kubernetes/kubernetes/issues/67659

1. Attached to the case is the sos report of the node
2. Appended is the output of  oc rsh --loglevel=8 <pod_name>

Comment 1 Seth Jennings 2018-11-14 15:13:50 UTC
Seems to be fixed by https://github.com/kubernetes/kubernetes/pull/67288

Looking to backport.

Comment 5 Madhusudan Upadhyay 2018-11-15 06:14:53 UTC
*** Bug 1649728 has been marked as a duplicate of this bug. ***

Comment 18 Jianwei Hou 2018-12-14 06:10:49 UTC
The advisory shipped v3.11.51. I've verified this is fixed in v3.11.51.

Comment 19 Luke Meyer 2018-12-14 14:39:53 UTC
Fix shipped with https://access.redhat.com/errata/RHBA-2018:3743 before being verified.


Note You need to log in before you can comment on or make changes to this bug.