Bug 1649729 - In Dashboard, log hyperlink is not working for Block manager user
Summary: In Dashboard, log hyperlink is not working for Block manager user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 4.0
Assignee: Alfonso Martínez
QA Contact: Sunil Angadi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 11:47 UTC by Uday kurundwade
Modified: 2020-02-08 09:31 UTC (History)
4 users (show)

Fixed In Version: ceph-14.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:44:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of block manager page (51.58 KB, image/png)
2018-11-14 11:47 UTC, Uday kurundwade
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 37371 0 None None None 2018-11-27 11:22:26 UTC
Github ceph ceph pull 25231 0 'None' closed mgr/dashboard: 'Logs' links permission in Landing Page 2020-01-23 16:20:11 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:45:06 UTC

Description Uday kurundwade 2018-11-14 11:47:23 UTC
Created attachment 1505620 [details]
Screenshot of block manager page

Description of problem:
In Dashboard, log hyperlink is not working for Block manager user

Version-Release number of selected component (if applicable):
ceph-common-12.2.8-23.el7cp.x86_64
ceph-ansible-3.2.0-0.1.beta9.el7cp.noarch
ceph-mgr-12.2.8-23.el7cp.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Install ceph storage
2.Install "dashboard v2" by running ansible playbook
3.Login to dashboard after installation of dashboard v2
4.Create new user and assign "Block manager" role to that user. 
5.Log in with newly created Block manager user.
6.In Home page, click on Cluster status-> Logs

Actual results:
Not displaying logs

Expected results:
It should display logs


Additional info:

Comment 3 Ernesto Puerta 2018-11-16 18:36:45 UTC
Alfonso: you know better thanme about the status of the Logs refactoring. This issue could be easily fixed by an NgIf/else, replacing the link to logs with a message "Please report your administrator", or simply nothing else. But let's see if the log refactor gets merged before this one.

Comment 4 Alfonso Martínez 2018-11-22 12:52:03 UTC
If the user doe not have permissions to see Logs,
the "Logs" link should not appear:

Upstream issue:
https://tracker.ceph.com/issues/37371

Comment 8 Sunil Angadi 2019-12-09 04:27:57 UTC
ceph version 14.2.4-68.el8cp (56dc8251bc571344bddddfabebcc93abd10c4f4a) nautilus (stable)
ceph-ansible-4.0.5-1.el8cp.noarch

In the above version, It's working as new feature in 4.0 with separate log section
and both cluster logs and audit logs showing the logs appropriately

Moving BZ to verified state.

Comment 10 errata-xmlrpc 2020-01-31 12:44:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.