Bug 1649732 - pcs rebase bug for 7.7
Summary: pcs rebase bug for 7.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Ivan Devat
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 12:02 UTC by Tomas Jelinek
Modified: 2019-08-06 13:10 UTC (History)
7 users (show)

Fixed In Version: pcs-0.9.167-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:10:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2244 None None None 2019-08-06 13:10:12 UTC

Description Tomas Jelinek 2018-11-14 12:02:57 UTC
pcs rebase bug for 7.7
We are still following pcs-0.9 branch.

Comment 3 Ivan Devat 2019-03-21 09:55:25 UTC
[0.9.167] - 2019-03-18
Added

    Command pcs client local-auth for authentication of pcs client against local pcsd. This is required when a non-root user wants to execute a command which requires root permissions (e.g. pcs cluster start). (rhbz#1554302)
    A warning is printed when adding a location constraint for a non-existent node (rhbz#1522858)
    Allow non-root users to read quorum status (commands pcs status corosync, pcs status quorum, pcs quorum device status, pcs quorum status) (rhbz#1594738)
    Command pcs config checkpoint diff for displaying differences between two specified checkpoints (rhbz#1515021)
    Support for resource instance attributes uniqueness check according to resource agent metadata (rhbz#1389140)
    Command pcs resource bundle reset for a bundle configuration reseting (rhbz#1598197)

Fixed

    pcsd.service now depends on network-online.target (rhbz#1638376)
    Propose removing nodes from their clusters instead of destroying cluster on the nodes when trying to create new cluster from nodes which are already in a cluster (rhbz#1474747)
    Pcs no longer removes empty meta_attributes, instance_attributes and other nvsets and similar elements from CIB. Such behavior was causing problems when pacemaker ACLs were in effect, leading to inability of pushing modified CIBs to pacemaker. (rhbz#1642514)
    pcs resource group add no longer produces an invalid CIB when group id is already occupied with non-resource element (rhbz#1447349)
    pcs no longer spawns unnecessary processes for reading node tokens (rhbz#1676944)
    Fixed a bug causing most of the messages not being logged into pcsd.log (rhbz#1679534)
    Lower load caused by periodical config files syncing in pcsd by making it sync less frequently (rhbz#1676956)
    Improve logging of periodical config files syncing in pcsd

[0.9.166] - 2018-09-30
Fixed

    Validation for an unaccessible resource inside a bundle (rhbz#1462248)
    Test of watchdog devices (rhbz#1475318)
    Possible race condition causing an HTTP 408 error when sending larger files via pcs (rhbz#1600169)
    Support diff-against option of pcs cluster cib-push only for crm_feature_set > 3.0.8 (rhbz#1488044)
    pcs resource delete accepts only one resource
    Show more user friendly error message when testing watchdog device and multiple devices are present (rhbz#1475318)
    Do not distinguish betwen supported and unsupported watchdog devices as SBD cannot reliably provide such information (rhbz#1475318)
    Instance attributes setting for fence agents fence_compute and fence_evacuate (rhbz#1623181)

Comment 7 errata-xmlrpc 2019-08-06 13:10:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2244


Note You need to log in before you can comment on or make changes to this bug.