Bug 1649768 - running ovn/ovs binaries throws a warning on missing shared libraries.
Summary: running ovn/ovs binaries throws a warning on missing shared libraries.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openvswitch
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 14.0 (Rocky)
Assignee: Open vSwitch development team
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 13:40 UTC by Miguel Angel Ajo
Modified: 2018-11-14 13:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-14 13:57:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miguel Angel Ajo 2018-11-14 13:40:37 UTC
Description of problem:

When we run any ovn/ovs binary we get warnings about missing shared libraries:

PMD: net_mlx5: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx5: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx5)
PMD: net_mlx4: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx4: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx4)

That looks bad for an admin trying to use the service, and looks like it's broken.


# ovs-nbctl --help
....

PKI configuration (required to use SSL):
  -p, --private-key=FILE  file with private key
  -c, --certificate=FILE  file with certificate for private key
  -C, --ca-cert=FILE      file with peer CA certificate
  --bootstrap-ca-cert=FILE  file with peer CA certificate to read or create
SSL options:
  --ssl-protocols=PROTOS  list of SSL protocols to enable
  --ssl-ciphers=CIPHERS   list of SSL ciphers to enable
PMD: net_mlx5: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx5: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx5)
PMD: net_mlx4: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx4: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx4)

Version-Release number of selected component (if applicable):

[root@controller-1 neutron]# docker exec ovn_controller rpm -qa | grep openvs
python-openvswitch2.10-2.10.0-21.el7fdn.x86_64
rhosp-openvswitch-2.10-0.1.el7ost.noarch
openvswitch2.10-ovn-common-2.10.0-21.el7fdn.x86_64
rhosp-openvswitch-ovn-host-2.10-0.1.el7ost.noarch
openvswitch-selinux-extra-policy-1.0-5.el7fdp.noarch
openvswitch2.10-2.10.0-21.el7fdn.x86_64
python-rhosp-openvswitch-2.10-0.1.el7ost.noarch
rhosp-openvswitch-ovn-common-2.10-0.1.el7ost.noarch
openvswitch2.10-ovn-host-2.10.0-21.el7fdn.x86_64

How reproducible:

100%

Steps to Reproduce:
1. try to run any ovs/ovn command line tool
2.
3.

Actual results:

Several warnings on the output 
PMD: net_mlx5: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx5: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx5)
PMD: net_mlx4: cannot load glue library: libibverbs.so.1: cannot open shared object file: No such file or directory
PMD: net_mlx4: cannot initialize PMD due to missing run-time dependency on rdma-core libraries (libibverbs, libmlx4)


Expected results:

No warnings

Additional info:

Comment 1 Timothy Redaelli 2018-11-14 13:57:54 UTC
It's fixed in FDP 18.11 (already released) since we link statically with OVS and we don't link with shared libraries anymore


Note You need to log in before you can comment on or make changes to this bug.