Bug 1649837 - neutron.get_floatingip method does not exist
Summary: neutron.get_floatingip method does not exist
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-kuryr-kubernetes
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: Upstream M2
: 15.0 (Stein)
Assignee: Luis Tomas Bolivar
QA Contact: GenadiC
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 15:38 UTC by GenadiC
Modified: 2019-09-26 10:46 UTC (History)
2 users (show)

Fixed In Version: openstack-kuryr-kubernetes-0.6.2-0.20190305141049.a019712.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:19:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 617919 0 None None None 2018-11-14 15:43:39 UTC
OpenStack gerrit 618123 0 None None None 2018-11-15 10:39:58 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:19:49 UTC

Description GenadiC 2018-11-14 15:38:14 UTC
Description of problem:

neutron.get_floatingip method does not exists, thus when there is a conflict assigning the floating ip, the checking to see if the FIP is already properly assigned will throw exceptions
Version-Release number of selected component (if applicable):


How reproducible:
It always happens when I run automation test in kuryr-tempest-plugin test_port_pool_update under test/scenario/test_port_pool.py

Steps to Reproduce:
1. Run the test
2. Check logs
3.

Actual results:
The test fails with the log provided

Expected results:
Test should pass

Additional info:
Following exception is received:
2018-11-13 20:06:16.373 1 DEBUG neutronclient.v2_0.client [-] Error message: {"NeutronError": {"message": "Cannot associate floating IP 172.24.5.64 (d4fd7026-6391-4875-84d9-f5226275640b) with port 208a65f8-9197-4fee-97fe-d0a1160b5a66 using fixed IP 10.1.0.146, as that fixed IP already has a floating IP on external network 336910a3-7f47-4fdc-9c4e-84787d794ea8.", "type": "FloatingIPPortAlreadyAssociated", "detail": ""}} _handle_fault_response /usr/lib/python2.7/site-packages/neutronclient/v2_0/client.py:259[00m
2018-11-13 20:06:16.374 1 WARNING kuryr_kubernetes.controller.drivers.public_ip [-] Conflict when assigning floating IP with id d4fd7026-6391-4875-84d9-f5226275640b. Checking if it's already assigned correctly.: Conflict: Cannot associate floating IP 172.24.5.64 (d4fd7026-6391-4875-84d9-f5226275640b) with port 208a65f8-9197-4fee-97fe-d0a1160b5a66 using fixed IP 10.1.0.146, as that fixed IP already has a floating IP on external network 336910a3-7f47-4fdc-9c4e-84787d794ea8.[00m
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry [-] Report handler unhealthy LoadBalancerHandler: AttributeError: 'Client' object has no attribute 'get_floatingip'
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry Traceback (most recent call last):
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/handlers/retry.py", line 55, in __call__
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry self._handler(event)
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/handlers/k8s_base.py", line 75, in __call__
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry self.on_present(obj)
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/handlers/lbaas.py", line 252, in on_present
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry if self._sync_lbaas_members(endpoints, lbaas_state, lbaas_spec):
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/handlers/lbaas.py", line 327, in _sync_lbaas_members
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry if self._sync_lbaas_pools(endpoints, lbaas_state, lbaas_spec):
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/handlers/lbaas.py", line 437, in _sync_lbaas_pools
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry if self._sync_lbaas_listeners(endpoints, lbaas_state, lbaas_spec):
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/handlers/lbaas.py", line 494, in _sync_lbaas_listeners
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry if self._sync_lbaas_loadbalancer(endpoints, lbaas_state, lbaas_spec):
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/handlers/lbaas.py", line 597, in _sync_lbaas_loadbalancer
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry service_pub_ip_info, lb.port_id)
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/drivers/lb_public_ip.py", line 98, in associate_pub_ip
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry service_pub_ip_info.ip_id, vip_port_id)
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/drivers/public_ip.py", line 157, in associate
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry self._update(res_id, vip_port_id)
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry File "/usr/lib/python2.7/site-packages/kuryr_kubernetes/controller/drivers/public_ip.py", line 144, in _update
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry fip = neutron.get_floatingip(res_id)
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry AttributeError: 'Client' object has no attribute 'get_floatingip'
2018-11-13 20:06:16.375 1 ERROR kuryr_kubernetes.handlers.retry [00m
2018-11-13 20:06:16.380 1 ERROR kuryr_kubernetes.handlers.logging [-] Failed to handle event {u'object': {u'kind': u'Endpoints', u'subsets': [{u'addresses': [{u'ip': u'10.1.1.221', u'targetRef': {u'kind': u'Pod', u'resourceVersion': u'1900', u'namespace': u'kuryr-namespace-2080560623', u'name': u'kuryr-pod-1987265040', u'uid': u'f3f422d2-e775-11e8-b4a1-bc764e049d77'}, u'nodeName': u'ubuntu-xenial-rax-dfw-0000499264'}], u'ports': [{u'protocol': u'TCP', u'port': 8080}]}], u'apiVersion': u'v1', u'metadata': {u'name': u'kuryr-service-694611545', u'namespace': u'kuryr-namespace-2080560623', u'resourceVersion': u'1911', u'creationTimestamp': u'2018-11-13T18:58:51Z', u'annotations': {u'openstack.org/kuryr-lbaas-spec': u'{"versioned_object.data": {"ip": "10.1.0.146", "lb_ip": null, "ports": [{"versioned_object.data": {"name": null, "port": 80, "protocol": "TCP"}, "versioned_object.name": "LBaaSPortSpec", "versioned_object.namespace": "kuryr_kubernetes", "versioned_object.version": "1.0"}], "project_id": "9a9223af836b4951bc765cc136e549d4", "security_groups_ids": ["d3cc05e5-61d2-4ed8-88f4-fc9dbd0e2d77", "ed39919c-ffee-4447-af3b-26f88528a66e"], "subnet_id": "830f05e5-1e80-43a9-a93a-ccb784f84c57", "type": "LoadBalancer"}, "versioned_object.name": "LBaaSServiceSpec", "versioned_object.namespace": "kuryr_kubernetes", "versioned_object.version": "1.0"}'}, u'selfLink': u'/api/v1/namespaces/kuryr-namespace-2080560623/endpoints/kuryr-service-694611545', u'uid': u'28d9f4b7-e776-11e8-b4a1-bc764e049d77'}}, u'type': u'ADDED'}: AttributeError: 'Client' object has no attribute 'get_floatingip'

Comment 10 errata-xmlrpc 2019-09-21 11:19:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.