Bug 164986 - The relationship between teTeX and Publishing TeX is unclear
The relationship between teTeX and Publishing TeX is unclear
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-03 06:45 EDT by George N. White III
Modified: 2013-07-02 19:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 03:21:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George N. White III 2005-08-03 06:45:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The tetex component contains the Japanese Publishing TeX, which has never been part of teTeX.   

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -qi tetex
2. look for mention of additions to the standard tetex distribution
3.
  

Actual Results:  The first docs the user sees are the standard teTeX docs, so unless the user knows to look for ptex they will never realize that ptex is not part of tetex.  Questions about ptex are being posted to the teTeX list.  Maybe the package should be called ptetex or p+tetex. 

Expected Results:  The relationship between the standard tetex distribution, redhat's tetex package, and ptex should be clear from reading the top-level documentation.

Additional info:

This is mainly an issue of making it easier for the user to look for additional information and report bugs in the right place.
Comment 1 Fedora Update System 2005-09-19 15:43:59 EDT
From User-Agent: XML-RPC

tetex-3.0-6.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 2 Mary Ellen Foster 2005-09-20 10:10:06 EDT
One thing: the note that's been added to the description has some funky grammar.
At least going by the update announcement (haven't updated my own machine yet to
see for myself), it looks like it now says:

    The Red Hat tetex package also contains software related to Japanese
    support for teTeX such as ptex, what is not a part of teTeX project.

I suspect that should read "... *which* is not a part of *the* teTeX project."
(proposed changes emphasised).
Comment 3 Jindrich Novy 2005-09-20 10:22:45 EDT
Mary, thanks, I was so much focused to fix bugs that I neglected grammar ;)

The fix will appear in the next update after some time.

Note You need to log in before you can comment on or make changes to this bug.