Bug 16499 - comps file parser is fragile
Summary: comps file parser is fragile
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-18 06:37 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-26 19:43:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff for an offending comps file (Server/Workstation copies) (737 bytes, patch)
2000-08-18 06:38 UTC, Pekka Savola
no flags Details | Diff

Description Pekka Savola 2000-08-18 06:37:11 UTC
If your 'comps' file is too long (too many packages it'd
seem), the installer halts without any errors in 'reading packages'
screen.  An example of an offending comps file is attached to bugzilla.
  
It doesn't matter if those packages have been included by '@ Development'
-like classes or typed in directly.      
  
Please note that you _can_ create a couple of new classes 
(I did so for our server class, and it worked fine), but it seems there's
some magic limit out there.

This has worked fine in RH 6.0 - 6.2.                               
                       
Kind of a showstopper for us package customizers.

Comment 1 Pekka Savola 2000-08-18 06:38:22 UTC
Created attachment 2636 [details]
diff for an offending comps file (Server/Workstation copies)

Comment 2 Glen Foster 2000-08-18 20:45:30 UTC
This defect is considered MUST-FIX for Winston Gold release

Comment 3 Matt Wilson 2000-08-21 17:08:40 UTC
works for me, at least in NFS...


Comment 4 Pekka Savola 2000-08-22 05:57:31 UTC
This works in RC2; perhaps the problem was inadvertly fixed.  Did you try it
using RC1 or RC2?

Comment 5 Pekka Savola 2000-09-15 22:13:11 UTC
This also happens with Gold release.

However, I don't think comps.diff attached will show the broken behaviour.

It might be that classes included with '@' may not contain empty lines.  
Regular classes Joe User can choose can do that just fine.

Removing all empty lines from within class definitions appeared to fix this.

I didn't have time to check what's causing this very thoroughly :-(


Comment 6 Matt Wilson 2000-09-17 22:58:26 UTC
Yes, empty lines are not allowed.  The comps parser isn't exactly wonderful. :|


Comment 7 Michael Fulbright 2002-07-17 15:54:09 UTC
We use XML now should not have these issues.

Comment 8 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.