Bug 1649903 - Configured Proxy Under Advanced Configuration For OpenShift Provider is Not Used
Summary: Configured Proxy Under Advanced Configuration For OpenShift Provider is Not Used
Keywords:
Status: ON_DEV
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.11.5
Assignee: Daniel Berger
QA Contact: juwatts
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-14 18:21 UTC by juwatts
Modified: 2020-02-25 19:45 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)

Description juwatts 2018-11-14 18:21:25 UTC
Description of problem:
If a user configures a proxy server under https_proxy:openshift in the Advanced Configuration, requests are not passed through the proxy.


Version-Release number of selected component (if applicable):
5.10.0.23.20181106165157_92dd189
5.9.6.0.20181105224828_652732b

How reproducible:
100%

Steps to Reproduce:
1. Navigate to Configuration->Advanced
2. Add a host and port under http_proxy:openshift and click save
3. Configure a Containers provider

Actual results:
Requests are not passed through the proxy


Expected results:
Requests are passed through the proxy


Additional info:
If the user configures it under http_proxy:default, requests are passed through the proxy. 

Also tested for OpenStack and Rhevm, was seeing the same behavior.

Comment 20 Daniel Berger 2019-10-30 14:58:53 UTC
Justin, are you seeing any errors in the evm.log, or the provider log?

Comment 25 Sudhir Mallamprabhakara 2019-12-11 14:35:36 UTC
Justin - Can you re-test on 5.11??


Note You need to log in before you can comment on or make changes to this bug.