Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1649940 - novajoin does not have permission to write the krb5 principle to its krb5.keytab
Summary: novajoin does not have permission to write the krb5 principle to its krb5.keytab
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novajoin
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Harry Rybacki
QA Contact: Jeremy Agee
URL:
Whiteboard:
Depends On:
Blocks: 1645136 1653312
TreeView+ depends on / blocked
 
Reported: 2018-11-14 21:15 UTC by Jeremy Agee
Modified: 2018-11-26 19:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-26 19:21:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1803578 0 None None None 2018-11-15 15:54:54 UTC
OpenStack gerrit 618275 0 None None None 2018-11-19 16:10:43 UTC

Description Jeremy Agee 2018-11-14 21:15:52 UTC
Description of problem:
When the undercloud is deploying, the krb5.keytab inside of the container can not store its krb principle.

Steps to Reproduce:
1. deploy the undercloud with novajoin enabled

Actual results:
novajoin is not fully setup.

Expected results:
Novajoin will be able to enrole overcloud nodes

Comment 1 Harry Rybacki 2018-11-26 19:21:23 UTC
We have been unable to reproduce this bug since mid-last week. Closing for now. We will re-open if the bug re-occurs.


Note You need to log in before you can comment on or make changes to this bug.