Bug 1649991 - [RFE] PV size is not at least the size of the PVC request (~1% off due to Gluster, and file system overhead)
Summary: [RFE] PV size is not at least the size of the PVC request (~1% off due to Glu...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: ocs-3.11
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: John Mulligan
QA Contact: Prasanth
URL: https://lists.gluster.org/pipermail/g...
Whiteboard:
Depends On:
Blocks: 1642302
TreeView+ depends on / blocked
 
Reported: 2018-11-15 05:07 UTC by Kedar Bidarkar
Modified: 2019-04-01 14:15 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-01 14:15:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github heketi heketi issues 1424 None None None 2018-11-15 11:01:19 UTC

Description Kedar Bidarkar 2018-11-15 05:07:21 UTC
Description of problem:

Allocating a single large file on a PVC fails with ENOSPC eventhough nothing else has been written to it.

Version-Release number of selected component (if applicable):


How reproducible:
Create a PVC of 4GiB and allocate a 4GiB file in it.

Steps to Reproduce: ( With CNV setup , for example )
1. create a PVC of size 4GB
2. Create a VM with the above created PVC
3.

Actual results:

Allocating a single large file on a PVC fails with ENOSPC eventhough nothing else has been written to it.

Expected results:

It should be possible to allocate a single large file with the size of the requested PVC. A 4GiB PVC should be able to store a 4GiB file.

Additional info:

https://github.com/heketi/heketi/issues/1424

This issue is not seen when using local storage.

A 4GB disk.img file does get created under the local storage path successfully.

Comment 2 Niels de Vos 2018-11-15 13:48:14 UTC
More details in https://bugzilla.redhat.com/show_bug.cgi?id=1642302#c44 when disabling the storage.reserve option. Still 33MB of 4GB has been consumed.

Comment 3 Fabian Deutsch 2018-11-15 14:10:08 UTC
This is affecting a common flow with CNV.

Comment 4 Yaniv Kaul 2019-04-01 06:57:32 UTC
(In reply to Fabian Deutsch from comment #3)
> This is affecting a common flow with CNV.

Irrelevant now for CNV, do we wish to fix this? I think a slight overhead is OK'ish.

Comment 5 John Mulligan 2019-04-01 14:15:46 UTC
I'm in favor of not doing anything no-one is asking for. :-)
Setting to WONTFIX and if it turns out it really is needed we can reopen it.


Note You need to log in before you can comment on or make changes to this bug.