Bug 1650010 - [admin] No Resources Found should be removed from hidden section on Status page when normal user does not have any project
Summary: [admin] No Resources Found should be removed from hidden section on Status pa...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-15 06:25 UTC by XiaochuanWang
Modified: 2019-03-12 14:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When no resources are found for a list page, a default empty state message is displayed. Consequence: On the Status page, the default empty state message is used when a project does not have any resources to display there. Fix: Add a special case to show a better empty state message on the status page when no overview items are available. This empty state provides more information and actions to take to get started. Result: A more meaningful and useful empty state is displayed on the status page when a user has an empty project.
Clone Of:
Environment:
Last Closed: 2019-01-15 14:22:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
the wrong display as no resource found (119.33 KB, image/png)
2019-01-15 09:12 UTC, XiaochuanWang
no flags Details

Description XiaochuanWang 2018-11-15 06:25:50 UTC
Description of problem:
User does not have any project, login and check Status page, there is "No Resources Found" in the hidden section. 

Version-Release number of selected component (if applicable):
Openshift v4.0.0-0.57.0
registry.reg-aws.openshift.com:443/openshift/ose-console                   v4.0                77d6a7fb5cb9 

How reproducible:
Always

Steps to Reproduce:
1. Make sure user does not have any project, login and check Status page.

Actual results:
1. There is "No Resources Found" in the hidden section. 

Expected results:
1. The "No Resources Found" should be removed under current project which is "default"

Additional info:

Comment 1 Samuel Padgett 2018-12-10 16:36:46 UTC
Jon, is it easy to show something else when showing the "fake" message?

Comment 2 Jon Jackson 2018-12-11 20:08:29 UTC
It would be pretty easy to replace this with a custom message or react component. We would just need to figure out what would go in its place.

Comment 3 Jon Jackson 2018-12-14 20:54:06 UTC
https://github.com/openshift/console/pull/951

Comment 4 XiaochuanWang 2019-01-15 09:12:21 UTC
Created attachment 1520676 [details]
the wrong display as no resource found

Comment 5 XiaochuanWang 2019-01-15 09:15:03 UTC
On Status page it still displays "No Resources Found" and url is overview/ns/default, please refer to the screenshot(attachment), thanks!

Tested on the version:
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-15-010905   True        False         11m       Cluster version is 4.0.0-0.nightly-2019-01-15-010905

Comment 6 Samuel Padgett 2019-01-15 14:22:55 UTC
This is expected for system namespaces like default. We don't show the empty state message with add-to-project buttons because we don't want to encourage users to add content to system namespaces. See

https://github.com/openshift/console/pull/967

I'm not sure what else we should show here. We could display a 403 forbidden error, but that seems less friendly. Here the content uses a disabled style to indicate that it's not active/real, and there's a clear call-to-action at the top of the page. You probably only get here by ignoring the message to create a project when first logging in.

> Expected results:
> 1. The "No Resources Found" should be removed under current project which is "default"

I think it would look more broken if we leave the entire area below Project Status blank.

There's a fine line between not found and forbidden. If you have an account with limited permissions, you might not know if a resource doesn't exist or if you simply don't have permission to view.

For the reasons above, I think this is a design choice and not a bug. The UI is working as intended.


Note You need to log in before you can comment on or make changes to this bug.