Bug 1650101 - [abrt] dnf: getRPMRepo(): transaction.py:788:getRPMRepo:RuntimeError: Statement: no such table: trans_item in
Summary: [abrt] dnf: getRPMRepo(): transaction.py:788:getRPMRepo:RuntimeError: Stateme...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a0d7fec1768056e36f4d17cab68...
: 1645790 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-15 11:12 UTC by Patrick Thies
Modified: 2019-08-31 01:38 UTC (History)
7 users (show)

Fixed In Version: dnf-4.2.5-4.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-31 01:38:32 UTC


Attachments (Terms of Use)
File: _var_log_dnf.log (211.33 KB, text/plain)
2018-11-15 11:12 UTC, Patrick Thies
no flags Details
File: backtrace (2.75 KB, text/plain)
2018-11-15 11:13 UTC, Patrick Thies
no flags Details
File: cgroup (389 bytes, text/plain)
2018-11-15 11:13 UTC, Patrick Thies
no flags Details
File: cpuinfo (1.39 KB, text/plain)
2018-11-15 11:13 UTC, Patrick Thies
no flags Details
File: dnf-makecache.log (54.21 KB, text/plain)
2018-11-15 11:13 UTC, Patrick Thies
no flags Details
File: environ (5.69 KB, text/plain)
2018-11-15 11:13 UTC, Patrick Thies
no flags Details
File: mountinfo (3.54 KB, text/plain)
2018-11-15 11:13 UTC, Patrick Thies
no flags Details
File: namespaces (129 bytes, text/plain)
2018-11-15 11:13 UTC, Patrick Thies
no flags Details
File: open_fds (2.73 KB, text/plain)
2018-11-15 11:13 UTC, Patrick Thies
no flags Details

Description Patrick Thies 2018-11-15 11:12:52 UTC
Description of problem:
dnf list 

after a rm -rf /var/lib/dnf/history/*


and pkcon doesn't work, either, so no more updates for me

Version-Release number of selected component:
dnf-4.0.4-1.fc29

Additional info:
reporter:       libreport-2.9.6
cmdline:        /usr/bin/python3 /usr/bin/dnf list
crash_function: getRPMRepo
exception_type: RuntimeError
executable:     /usr/bin/dnf
interpreter:    python3-3.7.1-1.fc29.x86_64
kernel:         4.18.16-300.fc29.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
transaction.py:788:getRPMRepo:RuntimeError: Statement: no such table: trans_item in

        SELECT
            repo.repoid as repoid
        FROM
            trans_item ti
        JOIN
            rpm USING (item_id)
        JOIN
            repo ON ti.repo_id == repo.id
        WHERE
            ti.action not in (3, 5, 7, 10)
            AND rpm.name = ?
            AND rpm.epoch = ?
            AND rpm.version = ?
            AND rpm.release = ?
            AND rpm.arch = ?
        ORDER BY
            ti.id DESC
        LIMIT 1;
    

Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 1055, in run
    return self.command.run()
  File "/usr/lib/python3.7/site-packages/dnf/cli/commands/__init__.py", line 232, in run
    self.opts.packages)
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 402, in output_packages
    columns = _list_cmd_calc_columns(self.output, ypl)
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 105, in _list_cmd_calc_columns
    _add_pkg_simple_list_lens(data, pkg)
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 93, in _add_pkg_simple_list_lens
    rid = len(pkg._from_repo)
  File "/usr/lib/python3.7/site-packages/dnf/package.py", line 84, in _from_repo
    pkgrepo = self.base.history.repo(self)
  File "/usr/lib/python3.7/site-packages/dnf/db/history.py", line 362, in repo
    return self.swdb.getRPMRepo(str(pkg))
  File "/usr/lib64/python3.7/site-packages/libdnf/transaction.py", line 788, in getRPMRepo
    return _transaction.Swdb_getRPMRepo(self, nevra)
RuntimeError: Statement: no such table: trans_item in

        SELECT
            repo.repoid as repoid
        FROM
            trans_item ti
        JOIN
            rpm USING (item_id)
        JOIN
            repo ON ti.repo_id == repo.id
        WHERE
            ti.action not in (3, 5, 7, 10)
            AND rpm.name = ?
            AND rpm.epoch = ?
            AND rpm.version = ?
            AND rpm.release = ?
            AND rpm.arch = ?
        ORDER BY
            ti.id DESC
        LIMIT 1;
    

Local variables in innermost frame:
self: <libdnf.transaction.Swdb; proxy of <Swig Object of type 'libdnf::Swdb *' at 0x7f5acc4ef2a0> >
nevra: '0ad-0.0.23-3.fc29.x86_64'

Comment 1 Patrick Thies 2018-11-15 11:12:59 UTC
Created attachment 1506022 [details]
File: _var_log_dnf.log

Comment 2 Patrick Thies 2018-11-15 11:13:01 UTC
Created attachment 1506023 [details]
File: backtrace

Comment 3 Patrick Thies 2018-11-15 11:13:02 UTC
Created attachment 1506024 [details]
File: cgroup

Comment 4 Patrick Thies 2018-11-15 11:13:03 UTC
Created attachment 1506025 [details]
File: cpuinfo

Comment 5 Patrick Thies 2018-11-15 11:13:05 UTC
Created attachment 1506026 [details]
File: dnf-makecache.log

Comment 6 Patrick Thies 2018-11-15 11:13:07 UTC
Created attachment 1506027 [details]
File: environ

Comment 7 Patrick Thies 2018-11-15 11:13:08 UTC
Created attachment 1506028 [details]
File: mountinfo

Comment 8 Patrick Thies 2018-11-15 11:13:10 UTC
Created attachment 1506029 [details]
File: namespaces

Comment 9 Patrick Thies 2018-11-15 11:13:11 UTC
Created attachment 1506030 [details]
File: open_fds

Comment 10 Daniel Mach 2019-06-02 04:41:49 UTC
*** Bug 1645790 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2019-08-14 07:23:45 UTC
FEDORA-2019-d4b6ede072 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4b6ede072

Comment 13 Fedora Update System 2019-08-16 20:12:10 UTC
dnf-4.2.5-4.fc29, dnf-plugins-extras-4.0.4-2.fc29, libdnf-0.31.0-6.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4b6ede072

Comment 14 Fedora Update System 2019-08-31 01:38:32 UTC
dnf-4.2.5-4.fc29, dnf-plugins-extras-4.0.4-2.fc29, libdnf-0.31.0-6.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.