Bug 1650244 - [v2v][osp] Virt-v2v logs contain OpenStack password in plain text
Summary: [v2v][osp] Virt-v2v logs contain OpenStack password in plain text
Keywords:
Status: CLOSED DUPLICATE of bug 1651426
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: libguestfs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.3.0
: ---
Assignee: Tomáš Golembiovský
QA Contact: meital avital
URL:
Whiteboard: v2v
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-15 16:21 UTC by Kedar Kulkarni
Modified: 2019-01-08 12:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-08 12:16:58 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)

Description Kedar Kulkarni 2018-11-15 16:21:41 UTC
Description of problem:
Virt-v2v  logs contain OpenStack password in plain text

Version-Release number of selected component (if applicable):
virt-v2v-1.38.2-12.22.lp.el7ev.x86_64
# Wrapper version
VERSION = "9.1"

How reproducible:
100%

Steps to Reproduce:
1.Configure conversion appliance on OpenStack
2.Add OpenStack and VMware provider to CFME
3.Create infra mapping and migration plan
4.Run Migration
5.Watch virt-v2v logs

Actual results:
Password exposed as plain text

Expected results:
password should be confiscated

Additional info:

Comment 2 Tomáš Golembiovský 2019-01-08 12:16:58 UTC

*** This bug has been marked as a duplicate of bug 1651426 ***


Note You need to log in before you can comment on or make changes to this bug.