Bug 165027 - Popen3 call in smart/backends/solaris/pm.py hangs
Popen3 call in smart/backends/solaris/pm.py hangs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
500
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Wregglesworth
Max Spevack
:
Depends On:
Blocks: 152252
  Show dependency treegraph
 
Reported: 2005-08-03 13:54 EDT by John Wregglesworth
Modified: 2007-06-26 11:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 16:28:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2005-08-03 13:54:09 EDT
Description of problem: When attempting to install a patch cluster on a solaris
machine (8, 9, or 10), the call to unzip hangs. Unzip is called using a
popen2.Popen3 object. It appears that the output file descriptor needs to have a
bit read from it, and then be closed.

How reproducible: Always


Steps to Reproduce:
1. Schedule a patch cluster install
2. Run rhn_check on the client machine
3. Watch the unzip call hang
  
Actual results: The patch cluster install hangs.


Expected results: The patch cluster installs.
Comment 1 John Wregglesworth 2005-08-03 14:12:23 EDT
Fixed in SVN.

I added a few lines to smart/backends/solaris/pm.py that will read a bit from
the fromchild file object and close it, which should allow unzip to run without
hanging.

Test Plan.
1. Register a solaris client to a satellite to a satellite and subscribe it to a
channel that contains a patch cluster package.

2. Schedule an installation of the patch cluster package.

3. Run rhn_check -vvv on the solaris client and make sure it doesn't hang when
unzipping the pkg. It can take a while for the patch cluster to unzip and install.
Comment 2 Max Spevack 2005-08-10 22:13:41 EDT
up2date patch cluster -- the call to unzip doesn't hang, it just takes forever
since the patch cluster is huge.

PROD_READY -28

Note You need to log in before you can comment on or make changes to this bug.