Bug 1650393 - backport two memory leak fixes in snmplib
Summary: backport two memory leak fixes in snmplib
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: net-snmp
Version: 7.6
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Josef Ridky
QA Contact: David Jež
URL:
Whiteboard:
Depends On:
Blocks: 1653362
TreeView+ depends on / blocked
 
Reported: 2018-11-16 04:59 UTC by Masahiro Matsuya
Modified: 2019-08-06 13:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1653362 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:08:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2239 None None None 2019-08-06 13:08:57 UTC

Description Masahiro Matsuya 2018-11-16 04:59:50 UTC
Description of problem:

The two memory leaks were fixed in snmplib on upstream. Our customer worked for that on the upstream. They have this memory leak issue actually on RHEL7 machine, and they would like us to backport the patches.

 [1] https://sourceforge.net/p/net-snmp/code/ci/c6facf2f080c9e1ea803e4884dc92889ec83d990/

 [2] https://sourceforge.net/p/net-snmp/code/ci/67726f2a74007b5b4117fe49ca1e02c86110b624/

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.6

How reproducible:
Always with reproducer for second memory leak.
Customer can reproduce both memory leak.

Steps to Reproduce:
I will write it in another private comment.

Actual results:
memory leak happens.

Expected results:
memory leak doesn't happen.

Additional info:

The following is the related discussion on upstream.

First memory leak:

https://sourceforge.net/p/net-snmp/mailman/message/36436934/
https://sourceforge.net/p/net-snmp/mailman/message/36437024/

Second memory leak:

https://sourceforge.net/p/net-snmp/mailman/message/36437618/
https://sourceforge.net/p/net-snmp/mailman/message/36437956/

Comment 5 Josef Ridky 2018-11-21 10:19:57 UTC
@dkutalek may I ask you for qa_ack?

Comment 13 errata-xmlrpc 2019-08-06 13:08:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2239


Note You need to log in before you can comment on or make changes to this bug.