Bug 1650403 - Memory leaks observed in brick-multiplex scenario on volume start/stop loop
Summary: Memory leaks observed in brick-multiplex scenario on volume start/stop loop
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1650138
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-16 05:56 UTC by Pranith Kumar K
Modified: 2019-03-25 16:31 UTC (History)
3 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1650138
Environment:
Last Closed: 2019-03-25 16:31:57 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21661 0 None Open features/changelog: Fix dictionary-leak 2018-11-23 06:57:48 UTC
Gluster.org Gerrit 21761 0 None Open core: Resolve dict_leak at the time of destroying graph 2019-01-14 04:02:36 UTC
Gluster.org Gerrit 21773 0 None Open Don't depend on string options to be valid always 2018-12-17 17:19:48 UTC
Gluster.org Gerrit 21789 0 None Open features/snapview-client: access priv->path inside lock 2018-12-17 12:26:14 UTC
Gluster.org Gerrit 21876 0 None Open snapview-client: Don't free dictionary memory 2018-12-17 11:33:49 UTC
Gluster.org Gerrit 21979 0 None Open rpcsvc: Don't expect dictionary values to be available 2019-01-07 03:18:23 UTC

Comment 1 Vijay Bellur 2018-11-16 07:38:42 UTC
Description of problem:

Memory leak observed in glusterfsd processes when there are multiple PVCs starting in a few seconds

Expected results:

glusterfsd should not leak memory

Comment 2 Worker Ant 2018-11-23 06:57:47 UTC
REVIEW: https://review.gluster.org/21661 (features/changelog: Fix dictionary-leak) posted (#2) for review on master by Amar Tumballi

Comment 3 Worker Ant 2018-12-17 05:15:17 UTC
REVIEW: https://review.gluster.org/21789 (features/snapview-client: access priv->path inside lock) posted (#8) for review on master by Pranith Kumar Karampuri

Comment 4 Worker Ant 2018-12-17 11:08:11 UTC
REVIEW: https://review.gluster.org/21773 (Don't depend on string options to be valid always) posted (#9) for review on master by Pranith Kumar Karampuri

Comment 5 Worker Ant 2018-12-17 11:10:07 UTC
REVIEW: https://review.gluster.org/21761 (core: Resolve dict_leak at the time of destroying graph) posted (#13) for review on master by Pranith Kumar Karampuri

Comment 6 Worker Ant 2018-12-17 11:33:49 UTC
REVIEW: https://review.gluster.org/21876 (snapview-client: Don't free dictionary memory) posted (#1) for review on master by Pranith Kumar Karampuri

Comment 7 Worker Ant 2018-12-17 12:26:13 UTC
REVIEW: https://review.gluster.org/21789 (features/snapview-client: access priv->path inside lock) posted (#11) for review on master by Amar Tumballi

Comment 8 Worker Ant 2018-12-17 17:19:48 UTC
REVIEW: https://review.gluster.org/21773 (Don't depend on string options to be valid always) posted (#13) for review on master by Amar Tumballi

Comment 9 Worker Ant 2019-01-07 03:18:23 UTC
REVIEW: https://review.gluster.org/21979 (rpcsvc: Don't expect dictionary values to be available) posted (#3) for review on master by Amar Tumballi

Comment 10 Worker Ant 2019-01-14 04:02:36 UTC
REVIEW: https://review.gluster.org/21761 (core: Resolve dict_leak at the time of destroying graph) posted (#20) for review on master by Amar Tumballi

Comment 11 Shyamsundar 2019-03-25 16:31:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.