Bug 165041 - /tmp doesn't get cleaned up after a patch cluster installs
/tmp doesn't get cleaned up after a patch cluster installs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
500
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Wregglesworth
Max Spevack
:
Depends On:
Blocks: 152252
  Show dependency treegraph
 
Reported: 2005-08-03 15:39 EDT by John Wregglesworth
Modified: 2007-06-26 11:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 17:20:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2005-08-03 15:39:11 EDT
Description of problem: If you install a patch cluster by scheduling the install
in the WebUI and then running rhn_check on the client, the /tmp directory isn't
cleaned up afterwards. If the patch cluster is huge, it could cause subsequent
installs to fail due to lack of space.


How reproducible: Always


Steps to Reproduce:
1. Schedule a patch cluster install.
2. run rhn_check -vvv on the client
  
Actual results: The patch cluster installs, but the files placed in /tmp are not
removed afterwards.


Expected results: The files placed in /tmp are removed.


Additional info:
Comment 1 John Wregglesworth 2005-08-03 15:53:52 EDT
Fixed in SVN.

Turns out that there was an if-statement that always evaluated to false, which
was keeping stuff from being cleaned out of /tmp.

Test Plan

1. Schedule a patch cluster install for a solaris client.
2. Run rhn_check -vvv on the solaris client.
3. After the patch cluster install, check the /tmp/ directory to make sure that
the files are gone. The directory created in /tmp by the patch cluster install
will still exist, and the directory under that named after the patch cluster
will still exist, but there should be any files under that. For example, an ls
would look like this:

bash-3.00# ls -l /tmp/tmpf0NGmp/J2SE_Solaris_9_Recommended/
total 0
Comment 2 John Wregglesworth 2005-08-03 15:56:19 EDT
Correction: There should NOT be any files in the directory named after the patch
cluster.
Comment 3 Max Spevack 2005-08-10 22:20:44 EDT
That's correct.  PROD_READY

root@rhnsun3 /tmp/tmpMVQXtL/8_Recommended % ls -la
total 32
drwxr-xr-x   2 root     other         69 Aug 10 16:33 ./
drwxr-xr-x   3 root     other        115 Aug 10 15:44 ../

Note You need to log in before you can comment on or make changes to this bug.