Bug 1650422 - "Penalizing host <> because it is not preferred" logs are shown for VMs even if there are no preferred hosts
Summary: "Penalizing host <> because it is not preferred" logs are shown for VMs even...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.7
Hardware: All
OS: All
low
medium
Target Milestone: ovirt-4.3.0
: ---
Assignee: Milan Zamazal
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-16 06:43 UTC by nijin ashok
Modified: 2019-08-28 13:19 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.3.0_rc
Doc Type: Bug Fix
Doc Text:
Red Hat Virtualization Manager no longer logs messages regarding non-preferred host penalizations if the VM is not configured to have a preferred host.
Clone Of:
Environment:
Last Closed: 2019-05-08 12:39:01 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1085 None None None 2019-05-08 12:39:14 UTC
oVirt gerrit 95792 master MERGED core: Don't penalize if there are no preferred hosts 2018-11-29 11:42:30 UTC

Description nijin ashok 2018-11-16 06:43:45 UTC
Description of problem:

Even if we didn't select a "prefered host" for a VM, as a part of HA restart of this VM, it will show this message.

2018-11-16 00:48:00,904-05 INFO  [org.ovirt.engine.core.bll.scheduling.policyunits.PreferredHostsWeightPolicyUnit] (EE-ManagedThreadFactory-engineScheduled-Thread-61) [7a61de64] Penalizing host '10.65.177.82' because it is not preferred.

This is confusing and can be interpreted as the VM will not be scheduled on this host. I think these logs should be only shown if the VM is having "prefered hosts" selected.


Version-Release number of selected component (if applicable):

RHV 4.2.7

How reproducible:

100%

Steps to Reproduce:

1. Any HA flow.

Comment 1 Ryan Barry 2018-11-17 13:42:58 UTC
Lowering the severity because it's logs only

Comment 2 RHV Bug Bot 2018-12-10 15:13:00 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 3 Pedut 2018-12-13 14:18:40 UTC
Verified on 4.3.0-0.4.master.20181207184726.git7928cae.el7.

Comment 4 RHV Bug Bot 2019-01-15 23:35:29 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 6 Raz Tamir 2019-01-28 20:30:57 UTC
QE verification bot: the bug was verified upstream

Comment 9 errata-xmlrpc 2019-05-08 12:39:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085

Comment 10 Daniel Gur 2019-08-28 13:14:19 UTC
sync2jira

Comment 11 Daniel Gur 2019-08-28 13:19:21 UTC
sync2jira


Note You need to log in before you can comment on or make changes to this bug.