Bug 1650460 - Installer help not mentioning how to provide array values for e.g.cert-names
Summary: Installer help not mentioning how to provide array values for e.g.cert-names
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Devendra Singh
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2018-11-16 08:49 UTC by Peter Vreman
Modified: 2020-01-15 20:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Peter Vreman 2018-11-16 08:49:48 UTC
Description of problem:
How to provide multiple items for a parameter that accepts an Array is not clear. Is it space-seprata or maybe comma-separate?
After 1h googling and looking i finally found that i can provide the option multiple times to provide multiple items in array.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run the installer and create a self-signed cert with 3 Alternative DNS names
2.
3.

Actual results:
No guidance in the --help

Expected results:
The --help mentioned that the --cert-cname, puppet-dns-alt-names and maybe other items accepting an array can be provided multiple times to add multiple items.

Additional info:

Comment 2 Bryan Kearney 2019-12-03 16:34:28 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 3 Bryan Kearney 2020-01-15 20:30:00 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.

Comment 4 Bryan Kearney 2020-01-15 20:30:09 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.