Bug 1650467 - unhelpful error message if cockit-ws is installed without cockpit-system
Summary: unhelpful error message if cockit-ws is installed without cockpit-system
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit
Version: 8.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 8.0
Assignee: Martin Pitt
QA Contact: Jan Ščotka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-16 09:22 UTC by Dominik Holler
Modified: 2019-06-11 19:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-23 11:53:18 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
terminal log (6.82 KB, text/plain)
2018-11-16 09:22 UTC, Dominik Holler
no flags Details
terminal log of uninstall of cockpit-system (6.30 KB, text/plain)
2018-11-19 17:27 UTC, Dominik Holler
no flags Details

Description Dominik Holler 2018-11-16 09:22:15 UTC
Created attachment 1506373 [details]
terminal log

Description of problem:
Logging into cockpit on rhel-8.0-beta-1-x86_64-kvm.qcow2 restults in
"Internal error in login process" in the web interface

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start VM from rhel-8.0-beta-1-x86_64-kvm.qcow2
2. in VM: systemctl enable --now cockpit.socket
3. try to loginto cockpit's web interface

Actual results:
"Internal error in login process" in the web interface

Expected results:
Login works

Additional info:

Comment 1 Martin Pitt 2018-11-19 09:37:37 UTC
The log says

cockpit-ws[806]: cockpit-session: can't exec cockpit-bridge: No such file or directory

So at first sight it seems you only installed cockpit-ws? You at least need cockpit-system as well. The recommended way is to install the "cockpit" metapackage, which will pull in everything required and recommended.

The "cockpit" package is part of the "default" RHEL install. Ironically, the installer does not actually enable the "default" install by default, it does a minimal install if you don't choose anything else. How exactly did you install this VM?

Comment 2 Dominik Holler 2018-11-19 09:41:02 UTC
The VM is the basic cloud image rhel-8.0-beta-1-x86_64-kvm.qcow2 .
Please find the full log of creating the VM in attachment 1506373 [details] .

Comment 3 Martin Pitt 2018-11-19 10:24:35 UTC
Thanks, I'll investigate this ASAP (I don't have much bandwidth right now).

Can you confirm that things work once you install cockpit-system? Just to ensure that it's really just the missing packages, not something else wrong.

Comment 4 Dominik Holler 2018-11-19 10:30:16 UTC
yes, installing cockpit-system fixes the issue.

Comment 5 Martin Pitt 2018-11-19 10:47:29 UTC
Thanks for confirming!

So apparently there's something wrong with the comps files. In

   https://code.engineering.redhat.com/gerrit/#/c/141569/

I cleaned them up a bit, but there are no records which just have "cockpit-ws" but not cockpit-system:

  https://code.engineering.redhat.com/gerrit/gitweb?p=comps.git;a=blob;f=comps-rhel-8.0-beta.xml.in
  https://code.engineering.redhat.com/gerrit/gitweb?p=comps.git;a=blob;f=comps-rhel-8.0.xml.in

I'll investigate how exactly the cloud images are being put together.

Comment 6 Martin Pitt 2018-11-19 17:06:47 UTC
I checked the current cloud image kickstart file, and it still looks correct:

https://code.engineering.redhat.com/gerrit/gitweb?p=spin-kickstarts.git;a=blob;f=rhel8/rhel-8.0-kvm.ks

I don't see a cloud image in http://downloads.redhat.com/redhat/rhel/rhel-8-beta/ , so I downloaded the nightly one from http://download-node-02.eng.bos.redhat.com/nightly/latest-RHEL-8/compose/BaseOS/x86_64/images/ (rhel-guest-image-8.0-XXXX.x86_64.qcow2).

Booting that in QEMU I see that it has cockpit-{ws,bridge,system} installed, as intended.

Do you have a pointer to where to get that image from?

Comment 7 Dominik Holler 2018-11-19 17:27:48 UTC
Created attachment 1507308 [details]
terminal log of uninstall of cockpit-system

Seems like uninstalling kexec-tools uninstalls cockpit-system, but not cockpit-ws.
So I uninstalled unintentionally cockpit-system, but cockpit-ws was still there.
One one hand this is my own mistake, on the other hand, it is confusing that cockpit-ws was still there without a helpful error message.

Comment 8 Martin Pitt 2018-11-19 21:46:24 UTC
Ah, that explains the mystery. Indeed cockpit-ws does not have a hard dependency on cockpit-system, as we want to support the cockpit/ws container and bastion host use cases -- i. e. a container or host which can only log into remote machines, not the local one. But the error message could be friendlier indeed.


Note You need to log in before you can comment on or make changes to this bug.