Bug 1650515 - pytest: Please switch Requires to platform-python-setuptools
Summary: pytest: Please switch Requires to platform-python-setuptools
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: pytest
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Python Maintainers
QA Contact: Jan Kepler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-16 11:31 UTC by Lumír Balhar
Modified: 2019-06-14 00:59 UTC (History)
3 users (show)

Fixed In Version: pytest-3.4.2-11.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-14 00:59:37 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Lumír Balhar 2018-11-16 11:31:24 UTC
Hello,

please switch the runtime dependency of python3-pytest from the package "python3-setuptools" to "platform-python-setuptools".

The platform-python-setuptools package is exactly the same, except it doesn't contain the user-facing executable `easy_install-3.6` which is not needed by this package. It's highly confusing to users to have the easy_install executable installed, but not python3 (BZ#1638836).

Comment 1 Lumír Balhar 2018-11-16 11:34:12 UTC
Pull request: https://src.osci.redhat.com/rpms/pytest/pull-request/1


Note You need to log in before you can comment on or make changes to this bug.