Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1650645 - ipa-client-automount fails to restart services
Summary: ipa-client-automount fails to restart services
Keywords:
Status: CLOSED DUPLICATE of bug 1645501
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: ipa
Version: 8.0
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: 8.0
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-16 17:24 UTC by Tony Coffman
Modified: 2018-12-18 10:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-18 10:19:28 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Tony Coffman 2018-11-16 17:24:05 UTC
Description of problem:

running ipa-client-automount fails to restart nfs services

Version-Release number of selected component (if applicable):

ipa-client-4.7.1-1.el8

How reproducible: 100%

Steps to Reproduce:
1. ipa-client-automount --location <map name>
2. enter yes to continue configuration

Actual results:

[root@test home]# ipa-client-automount --location nas
Searching for IPA server...
IPA server: DNS discovery
Location: nas
Continue to configure the system with these values? [no]: yes
Configured /etc/sysconfig/nfs
Configured /etc/idmapd.conf
rpcidmapd failed to restart: CalledProcessError(Command ['/bin/systemctl', 'restart', 'nfs-idmap.service'] returned non-zero exit status 5: 'Failed to restart nfs-idmap.service: Unit nfs-idmap.service not found.\n')
rpcgssd failed to restart: CalledProcessError(Command ['/bin/systemctl', 'restart', 'nfs-secure.service'] returned non-zero exit status 5: 'Failed to restart nfs-secure.service: Unit nfs-secure.service not found.\n')
Restarting sssd, waiting for it to become available.
Started autofs


Expected results:

Services restarted

Additional info:

Comment 1 Florence Blanc-Renaud 2018-12-03 16:40:33 UTC
See also BZ #1645501 comment 2 (https://bugzilla.redhat.com/show_bug.cgi?id=1645501#c2), probably the same root cause.

Comment 2 François Cami 2018-12-03 17:10:04 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/7783

Comment 5 Thomas Woerner 2018-12-18 10:19:28 UTC
This is related to the updates for #1645501 and has been fixed. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 1645501 ***


Note You need to log in before you can comment on or make changes to this bug.