Bug 1650674 - Wildcard resources in policies not matching objects with colons in the key
Summary: Wildcard resources in policies not matching objects with colons in the key
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.2
Hardware: All
OS: All
medium
medium
Target Milestone: z1
: 3.2
Assignee: Adam C. Emerson
QA Contact: Tejas
Aron Gunn
URL:
Whiteboard:
Depends On:
Blocks: 1629656
TreeView+ depends on / blocked
 
Reported: 2018-11-16 19:58 UTC by Adam C. Emerson
Modified: 2019-03-07 15:51 UTC (History)
12 users (show)

Fixed In Version: RHEL: ceph-12.2.8-76.el7cp Ubuntu: ceph_12.2.8-61redhat1
Doc Type: Bug Fix
Doc Text:
.Wildcard policies match objects with colons in the name Previously, using colons in the name caused an error in a matching function not allowing wildcards to match beyond colons. In this release, colons can be used to match objects.
Clone Of:
Environment:
Last Closed: 2019-03-07 15:50:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0475 None None None 2019-03-07 15:51:05 UTC
Github ceph ceph pull 25145 None None None 2018-11-16 20:08:43 UTC
Ceph Project Bug Tracker 23817 None None None 2018-11-16 19:58:39 UTC
Ceph Project Bug Tracker 37297 None None None 2018-11-16 20:07:08 UTC

Description Adam C. Emerson 2018-11-16 19:58:40 UTC
Description of problem:

Policies not being applied properly to resources with colons in the key.

How reproducible:


Steps to Reproduce:
1. Set a wildcard bucket on a policy granting access to a user
2. Upload an object with a : in the name
3. Try to download as that user

Actual results:

Failure to download

Expected results:

Success in downloading.

Comment 4 Adam C. Emerson 2018-11-16 20:08:44 UTC
Fix present. Will backport as soon as it's merged.

Comment 11 errata-xmlrpc 2019-03-07 15:50:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0475


Note You need to log in before you can comment on or make changes to this bug.