Bug 1650898 - libssh_threads.so.4 link is not created
Summary: libssh_threads.so.4 link is not created
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libssh
Version: 28
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Andreas Schneider
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-17 11:15 UTC by Oliver Sampson
Modified: 2019-02-07 15:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 15:07:07 UTC


Attachments (Terms of Use)

Description Oliver Sampson 2018-11-17 11:15:09 UTC
Description of problem:
Programs like x2goclient fail because there is no libssh_threads.so.4 file/link.

For example
x2goclient: error while loading shared libraries: libssh_threads.so.4: cannot open shared object file: No such file or directory


Version-Release number of selected component (if applicable):
uname -a
Linux xxxxx 4.18.18-200.fc28.x86_64 #1 SMP Mon Nov 12 03:17:32 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

dnf list | grep libssh
libssh.x86_64                             0.8.5-1.fc28                  @updates
libssh2.x86_64                            1.8.0-7.fc28                  @fedora 
libssh.i686                               0.8.5-1.fc28                  updates 
libssh-devel.i686                         0.8.5-1.fc28                  updates 
libssh-devel.x86_64                       0.8.5-1.fc28                  updates 
libssh2.i686                              1.8.0-7.fc28                  fedora  
libssh2-devel.i686                        1.8.0-7.fc28                  fedora  
libssh2-devel.x86_64                      1.8.0-7.fc28                  fedora  
libssh2-docs.noarch                       1.8.0-7.fc28                  fedora  
mingw32-libssh2.noarch                    1.8.0-3.fc27                  fedora  
mingw32-libssh2-static.noarch             1.8.0-3.fc27                  fedora  
mingw64-libssh2.noarch                    1.8.0-3.fc27                  fedora  
mingw64-libssh2-static.noarch             1.8.0-3.fc27                  fedora  
python2-libssh2.x86_64                    0.7.1-19.fc28                 fedora  
python3-libssh2.x86_64                    0.7.1-19.fc28                 fedora  
rust-libssh2-sys-devel.noarch             0.2.6-3.fc28                  fedora  


How reproducible:
Always

Steps to Reproduce:
1. Run x2goclient
2. See output
3.

Actual results:
Nothing.

Expected results:
A functioning program.


Additional info:

Workaround found on the forum:
https://forums.fedoraforum.org/showthread.php?319145-X2go-will-not-start-after-Fedora-28-update

with:
sudo ln -s /usr/lib64/libssh_threads.so.4.7.2 /usr/lib64/libssh_threads.so.4

Comment 1 Anderson Sasaki 2019-02-07 15:07:07 UTC
Thanks for reporting this issue!

This should be fixed since libssh-0.8.1-4 by the change in [0].
I can't reproduce the issue, for me the symlinks are always created when libssh is updated.

I'll close this bug, but feel free to reopen it if the problem persists even after updating x2goclient and libssh to the newest versions.

[0] https://src.fedoraproject.org/rpms/libssh/c/a1c8037c4c4a6db79cc532da76c5dcd32d3615cc?branch=f28


Note You need to log in before you can comment on or make changes to this bug.