Bug 1650922 - osd pool create w/bluestore shouldn't recommend use of 'expect_num_objects'
Summary: osd pool create w/bluestore shouldn't recommend use of 'expect_num_objects'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 3.2
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: 4.0
Assignee: Douglas Fuller
QA Contact: Manohar Murthy
Amrita
URL:
Whiteboard:
Depends On:
Blocks: 1730176 1750994 1641792
TreeView+ depends on / blocked
 
Reported: 2018-11-17 16:22 UTC by John Harrigan
Modified: 2020-01-31 12:45 UTC (History)
13 users (show)

Fixed In Version: ceph-14.2.1-385.g4ae8136.el8cp
Doc Type: Bug Fix
Doc Text:
.A message to set `expected_num_objects` is no longer shown when using BlueStore With this update, a message that recommends setting the `expected_num_obejcts` parameter during the creation of the BlueStore pools has been removed because this message does not apply when using the BlueStore OSD back end.
Clone Of:
Environment:
Last Closed: 2020-01-31 12:44:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 36494 None None None 2018-11-27 18:03:40 UTC
Github ceph ceph pull 24642 'None' closed osd/objectstore: change osd_objectstore default to bluestore 2020-01-30 22:19:52 UTC
Github ceph ceph pull 25937/ None None None 2020-01-30 22:19:51 UTC
Red Hat Product Errata RHBA-2020:0312 None None None 2020-01-31 12:45:06 UTC

Description John Harrigan 2018-11-17 16:22:13 UTC
Description of problem:
'osd pool create' recommends using expected_num_objects on bluestore based clusters. This parameter is only useful on filestore clusters.

Version-Release number of selected component (if applicable):
ceph-common.x86_64           2:12.2.8-36.el7cp

Steps to Reproduce:
1. # osd pool create <pgnum>
   For better initial performance on pools expected to store a large number of
   objects, consider supplying the expected_num_objects parameter when creating
   the pool.

Actual results:
cmd issues recommendation if pgnum exceeds threshold

Expected results:
cmd detects backing store type and only issues recommendation if on filestore 
based cluster and pgnum exceeds threshold

Additional info:

Comment 3 Douglas Fuller 2018-11-27 16:40:38 UTC
This occurs because the internal default value for osd_objectstore (even in master upstream) is still "filestore". That doesn't affect ceph-disk or ceph-volume, but it fools the check used by this warning.

Comment 4 Ken Dreyer (Red Hat) 2018-11-29 01:28:16 UTC
This does not sound like a blocker to 3.2. Can we re-target this to 4.0?

Comment 6 Yaniv Kaul 2019-01-23 14:23:04 UTC
Moving to MODIFIED, as it was merged in upstream.
I think CLOSED-NEXTRELEASE would be a good status for this one.

Comment 8 Josh Durgin 2019-06-05 22:56:36 UTC
This is fixed in all nautilus-based builds. Backporting to earlier releases required too many test changes, so moving this to 4.0.

Comment 11 Giridhar Ramaraju 2019-08-05 13:06:42 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 12 Giridhar Ramaraju 2019-08-05 13:09:19 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 20 errata-xmlrpc 2020-01-31 12:44:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.