Bug 1650931 - Tracer is non-functional
Summary: Tracer is non-functional
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tracer
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jakub Kadlčík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-17 17:54 UTC by Patrick O'Callaghan
Modified: 2019-02-01 01:58 UTC (History)
4 users (show)

Fixed In Version: tracer-0.7.1-2.fc28 tracer-0.7.1-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-01 01:41:15 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Patrick O'Callaghan 2018-11-17 17:54:35 UTC
Description of problem:
Running tracer after updating packages no longer shows any apps or services which need to be restarted.

Version-Release number of selected component (if applicable):
python3-tracer-0.7.0-3.fc29.noarch

How reproducible:
100%

Steps to Reproduce:
1.Update packages using dnf
2.
3.

Actual results:
Running tracer (under sudo) shows no results, even when it should.

Expected results:
List of apps or services which need to be restarted.

Additional info:
Problem is new with F29. I also have the dnf tracer plugin, which shows the same result, i.e. never lists any output even when I know for a fact that some running processes have had their packages changed. Using the '-a' option makes no difference.

IOW, 'sudo tracer' is now a no-op.

Comment 1 Eli Young 2018-11-26 22:00:58 UTC
This is ultimately caused by tracer making direct queries against the dnf history database, the location and schema of which has changed since Fedora 28. See https://github.com/FrostyX/tracer/issues/116

Comment 2 Fedora Update System 2019-01-09 10:50:16 UTC
tracer-0.7.1-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f76b1795e1

Comment 3 Fedora Update System 2019-01-09 10:50:21 UTC
tracer-0.7.1-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-65f497850d

Comment 4 Fedora Update System 2019-01-11 04:16:24 UTC
tracer-0.7.1-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f76b1795e1

Comment 5 Fedora Update System 2019-01-11 05:42:29 UTC
tracer-0.7.1-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-65f497850d

Comment 6 Fedora Update System 2019-02-01 01:41:15 UTC
tracer-0.7.1-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2019-02-01 01:58:43 UTC
tracer-0.7.1-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.