Bug 1650953 - Thinkpad P52 ELANTech ETPS/2 Touchpad Not Detected according to libinput
Summary: Thinkpad P52 ELANTech ETPS/2 Touchpad Not Detected according to libinput
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-18 01:01 UTC by cjrivera1
Modified: 2019-02-01 21:51 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-01 21:51:13 UTC


Attachments (Terms of Use)
Output of "libinput list-devices" (7.94 KB, text/plain)
2018-11-18 01:01 UTC, cjrivera1
no flags Details

Description cjrivera1 2018-11-18 01:01:57 UTC
Created attachment 1506848 [details]
Output of "libinput list-devices"

Description of problem:
According to libinput, using "libinput list-devices", the Thinkpad P52's built-in ELANTech ETPS/2 Touchpad is not detected in Fedora.

Version-Release number of selected component (if applicable):
4.18-300.fc29.x86_64

How reproducible:
This bug is reproduced every time the system boots.

Steps to Reproduce:
Install Fedora on a Thinkpad P52 and boot with the indicated kernel version.

Actual results:
"libinput list-devices" does not show the touchpad; Touchpad does not work.

Expected results:
"libinput list-devices" shows the touchpad; Touchpad works.

Additional info:
The touchpad did work in Fedora 28, under kernel version 4.17; however, since Fedora 28 upgraded to 4.18, the touchpad has not worked.

I have attached the output of "libinput list-devices".

Comment 1 Hin-Tak Leung 2018-11-21 23:49:53 UTC
FWIW, my "ETPS/2 Elantech Touchpad" (on a Acer laptop) had never worked properly from the beginning. I found that either:

1. disable some 'smart touchpad' setting in the bio, or
2. add 'i8042.nopnp=1' to the kernel command line.

either of those, I get to use the touch pad. I decided for option 2, since I suspect 1 is needed by windows. Although I don't use windows much (at all, actually), I rather not break it.

Comment 2 cjrivera1 2018-11-22 04:18:53 UTC
(In reply to Hin-Tak Leung from comment #1)
> FWIW, my "ETPS/2 Elantech Touchpad" (on a Acer laptop) had never worked
> properly from the beginning. I found that either:
> 
> 1. disable some 'smart touchpad' setting in the bio, or
> 2. add 'i8042.nopnp=1' to the kernel command line.
> 
> either of those, I get to use the touch pad. I decided for option 2, since I
> suspect 1 is needed by windows. Although I don't use windows much (at all,
> actually), I rather not break it.

Option 1 unfortunately won't work because that setting, for some ridiculous reason, doesn't exist in my bios.
Option 2 does not change the results I observe; the touchpad is still undetected by the tools I used.

Comment 3 Jeremy Cline 2018-12-03 17:29:04 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 29 kernel bugs.
 
Fedora 29 has now been rebased to 4.19.5-300.fc29.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you experience different issues, please open a new bug report for those.

Comment 4 cjrivera1 2018-12-07 17:48:17 UTC
I experience the same symptoms described previously, using kernel 4.19.6-300.fc29.x86_64, and booted with i8042.nopnp=1 as one of the arguments.

Comment 5 Justin M. Forbes 2019-01-29 16:13:07 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 29 kernel bugs.

Fedora 29 has now been rebased to 4.20.5-200.fc29.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 6 cjrivera1 2019-01-29 18:44:33 UTC
I experience the same symptoms described previously, using kernel 4.20.4-200.fc29.x86_64, and, again, booted with i8042.nopnp=1 as one of the arguments.
If there is any other information you need, I will provide it.

Comment 7 cjrivera1 2019-02-01 21:51:13 UTC
With kernel 4.20.5-200.fc29.x86_64, booted without the argument i8042.nopnp=1, my touchpad works.


Note You need to log in before you can comment on or make changes to this bug.