Bug 1650980 - Merkaartor crashes at startup with undefined symbol: _ZN10OGRFeature16GetFieldAsStringEi
Summary: Merkaartor crashes at startup with undefined symbol: _ZN10OGRFeature16GetFiel...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: merkaartor
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-18 12:33 UTC by Egon Kastelijn
Modified: 2019-02-09 02:12 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-02-09 02:12:54 UTC


Attachments (Terms of Use)

Description Egon Kastelijn 2018-11-18 12:33:38 UTC
Description of problem:
Merkaartor crashes at startup.

Version-Release number of selected component (if applicable):
FC29 merkaartor.x86_64  0.18.3-7.fc29

How reproducible:
Always

Steps to Reproduce:
1. dnf install merkaartor
2. merkaartor

Actual results:
merkaartor: symbol lookup error: merkaartor: undefined symbol: _ZN10OGRFeature16GetFieldAsStringEi 

Expected results:
Normal start of Merkaartor

Additional info:
-

Comment 1 Sven Lankes 2018-11-18 20:53:43 UTC
I can easily reproduce this issue.

Looks like a change related to a gdal/libgdal update.

I'll try an updated build as soon as possible and let you know.

Comment 2 Kevin Kofler 2019-01-25 18:03:20 UTC
Ping? I am still getting this error.

Comment 3 Kevin Kofler 2019-01-29 12:37:48 UTC
Looks like all that this needed is a rebuild. I rebuilt it successfully, trying it now.

Comment 4 Kevin Kofler 2019-01-29 14:08:47 UTC
Yes, that fixed it for me.

Comment 5 Fedora Update System 2019-01-29 14:11:53 UTC
merkaartor-0.18.3-8.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b7797b567f

Comment 6 Fedora Update System 2019-01-30 01:58:50 UTC
merkaartor-0.18.3-8.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b7797b567f

Comment 7 Fedora Update System 2019-02-09 02:12:54 UTC
merkaartor-0.18.3-8.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.