Bug 1651007 - resizefs doesn't work
Summary: resizefs doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: arm-image-installer
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-18 17:22 UTC by Ken
Modified: 2018-12-01 02:05 UTC (History)
1 user (show)

Fixed In Version: arm-image-installer-2.8-1.fc29 arm-image-installer-2.8-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-27 03:30:50 UTC


Attachments (Terms of Use)

Description Ken 2018-11-18 17:22:16 UTC
Description of problem:

resizefs doesn't work

Version-Release number of selected component (if applicable):

arm-image-installer-2.5-1.fc29.noarch


How reproducible:

Very


Steps to Reproduce:

1. arm-image-installer --image Fedora-Minimal-armhfp-29-1.2-sda.raw.xz --target orangepi_one --resizefs --media /dev/sdb


Actual results:


resize2fs 1.44.3 (10-July-2018)
The filesystem is already 306432 (4k) blocks long.  Nothing to do!


Expected results:


Resizing the filesystem on /dev/sdb3 to 823168 (4k) blocks.
The filesystem on /dev/sdb3 is now 823168 (4k) blocks long.



Additional info:

It looks like "sfdisk" is not run.  If I do it manually, it works :


MEDIA=/dev/sdb
PARTNUM=3
ROOTPART="${MEDIA}3"

echo ", +" | sfdisk -N "$PARTNUM" "$MEDIA"

fsck.ext4 -fy "$ROOTPART"
resize2fs "$ROOTPART"

Comment 1 Ken 2018-11-18 17:30:17 UTC
Bug seems to be because Fedora-Minimal-armhfp-29-1.2-sda.raw.xz has 3 partitions (whereas Fedora 28 ARM image had 4 partitions), but arm-image-installer only calls sfdisk when the image has 4 or 5 partitions.

Comment 2 Fedora Update System 2018-11-18 21:44:45 UTC
arm-image-installer-2.8-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-047eafec76

Comment 3 Fedora Update System 2018-11-18 21:44:53 UTC
arm-image-installer-2.8-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c5e677cac5

Comment 4 Fedora Update System 2018-11-19 04:31:26 UTC
arm-image-installer-2.8-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c5e677cac5

Comment 5 Fedora Update System 2018-11-19 04:58:01 UTC
arm-image-installer-2.8-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-047eafec76

Comment 6 Fedora Update System 2018-11-27 03:30:50 UTC
arm-image-installer-2.8-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2018-12-01 02:05:24 UTC
arm-image-installer-2.8-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.