Bug 1651038 - [Tracker RHGS#1651460] OCS upgrade doesn't regenerate volfiles
Summary: [Tracker RHGS#1651460] OCS upgrade doesn't regenerate volfiles
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-server-container
Version: ocs-3.11
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Saravanakumar
QA Contact: Prasanth
URL:
Whiteboard:
Depends On: 1651460
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-19 02:21 UTC by Atin Mukherjee
Modified: 2019-12-03 08:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-15 10:09:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1650138 None None None 2019-12-03 08:42:40 UTC
Red Hat Bugzilla 1651460 'medium' 'CLOSED' 'glusterd can''t regenerate volfiles in container storage upgrade workflow' 2019-12-03 08:42:40 UTC

Internal Links: 1650138 1651460

Description Atin Mukherjee 2018-11-19 02:21:30 UTC
Description of problem:

Background of the problem is captured at https://bugzilla.redhat.com/show_bug.cgi?id=1650138#c6 .

As part of an OCS upgrade process, glusterd isn't brought up with an interim mode ( glusterd --xlator-option *.upgrade=on -N) when the underlying RHGS NVR has changed. This command is run in the post install script of the glusterfs spec when an rpm is upgraded. This command is needed to ensure all the gluster bricks are started with the regenerated volfiles based on the latest bits.

Missing out this step as part of an OCS upgrade process can cause severe problems/side effects as explained in https://bugzilla.redhat.com/show_bug.cgi?id=1650138#c6

Version-Release number of selected component (if applicable):
All OCS versions

How reproducible:
every time


Note You need to log in before you can comment on or make changes to this bug.