Bug 1651039 - cockpit-composer does not let me do anything
Summary: cockpit-composer does not let me do anything
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit-composer
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Brian Lane
QA Contact: Release Test Team
Vladimír Slávik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-19 02:29 UTC by Neal Gompa
Modified: 2019-05-22 04:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-15 16:33:15 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showing the broken UI (22.95 KB, image/png)
2018-11-19 02:29 UTC, Neal Gompa
no flags Details

Description Neal Gompa 2018-11-19 02:29:49 UTC
Created attachment 1507057 [details]
Screenshot showing the broken UI

Description of problem:
After installing cockpit-composer, accessing Cockpit to go to the new image builder application leads to a UI that lets you do absolutely nothing.

Version-Release number of selected component (if applicable):
0.1.5-1.el8

How reproducible:
Always

Steps to Reproduce:
1. Install lorax-composer
2. Restart cockpit (if needed)
3. Connect to cockpit and attempt to use the image builder UI

Actual results:
The UI lets me do nothing...

Expected results:
The UI lets me do stuff to create images...

Additional info:

Comment 1 Martin Pitt 2018-11-19 07:30:41 UTC
Sounds like the lorax-composer backend failed to start?

Comment 2 Brian Lane 2018-11-26 19:19:04 UTC
(In reply to Neal Gompa from comment #0)
> Created attachment 1507057 [details]
> Screenshot showing the broken UI
> 
> Description of problem:
> After installing cockpit-composer, accessing Cockpit to go to the new image
> builder application leads to a UI that lets you do absolutely nothing.
> 
> Version-Release number of selected component (if applicable):
> 0.1.5-1.el8
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. Install lorax-composer
> 2. Restart cockpit (if needed)
> 3. Connect to cockpit and attempt to use the image builder UI
> 
> Actual results:
> The UI lets me do nothing...
> 
> Expected results:
> The UI lets me do stuff to create images...
> 
> Additional info:

Did you run 'systemctl enable lorax-composer.socket && systemctl start lorax-composer.socket' ?

http://weldr.io/lorax/f28-branch/lorax-composer.html#quickstart

You can check to see if things are working correctly from the cmdline using 'composer cli status show'

Comment 3 Neal Gompa 2018-11-26 20:31:58 UTC
$ composer-cli status show
2018-11-26 15:31:07,522: /run/weldr/api.socket does not exist

$ sudo composer-cli status show
2018-11-26 15:31:26,956: UnixHTTPConnectionPool(host='localhost', port=None): Max retries exceeded with url: /api/status (Caused by ProtocolError('Connection aborted.', ConnectionRefusedError(111, 'Connection refused')))

Comment 4 Neal Gompa 2018-11-26 20:33:19 UTC
I had done the following prior to running that:

$ sudo systemctl enable --now lorax-composer.socket
Created symlink /etc/systemd/system/sockets.target.wants/lorax-composer.socket → /usr/lib/systemd/system/lorax-composer.socket.

Comment 5 Brian Lane 2018-11-26 22:05:49 UTC
Next thing to do is to look at the output from journalctl and see why the service isn't being started. Do you have SELinux in Permissive mode?

Comment 6 Neal Gompa 2018-11-27 18:34:14 UTC
It took a reboot after doing so, but now it worked!

I wonder if it was just "stuck" after it failed initially...?

Comment 7 Brian Lane 2018-11-27 20:53:20 UTC
(In reply to Neal Gompa from comment #6)
> It took a reboot after doing so, but now it worked!
> 
> I wonder if it was just "stuck" after it failed initially...?

I think if the .socket doesn't successfully start the .service it gets stopped so that may be what happened. A start should start it up again w/o needing a reboot. But I'm not sure what failed in the first place that made it necessary to do that.

You can also look at the logs in /var/log/lorax-composer/composer.log and see if there's anything obvious (SELinux complaint or traceback of some kind).

Comment 8 Neal Gompa 2019-02-09 21:13:15 UTC
(In reply to Brian Lane from comment #7)
> (In reply to Neal Gompa from comment #6)
> > It took a reboot after doing so, but now it worked!
> > 
> > I wonder if it was just "stuck" after it failed initially...?
> 
> I think if the .socket doesn't successfully start the .service it gets
> stopped so that may be what happened. A start should start it up again w/o
> needing a reboot. But I'm not sure what failed in the first place that made
> it necessary to do that.
> 
> You can also look at the logs in /var/log/lorax-composer/composer.log and
> see if there's anything obvious (SELinux complaint or traceback of some
> kind).

Sorry, I meant to reply to this. Yeah, that's basically what happened.

Aside from the (already known) SELinux denials, it's otherwise fine.

Thanks for the help!


Note You need to log in before you can comment on or make changes to this bug.