Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1651123 - [RHOS14][dry-run] Dry run fails on ensure we create a new fetch_directory or use the old fetch_directory
Summary: [RHOS14][dry-run] Dry run fails on ensure we create a new fetch_directory or ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 14.0 (Rocky)
Assignee: Emilien Macchi
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-19 09:11 UTC by Gurenko Alex
Modified: 2019-01-11 11:54 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-9.0.1-0.20181013060888.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:54:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1803986 0 None None None 2018-11-19 13:27:24 UTC
OpenStack gerrit 618898 0 None MERGED ceph: allow curl tasks to run in dry run mode 2020-05-05 11:46:00 UTC
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:54:58 UTC

Description Gurenko Alex 2018-11-19 09:11:03 UTC
Description of problem: dry run fails its run on task: ensure we create a new fetch_directory or use the old fetch_directory


Version-Release number of selected component (if applicable): puddle 2018-11-13.1


How reproducible: 100%


Steps to Reproduce:
1. Try performing dry run according to docs
2.
3.

Actual results:

TASK [ensure we create a new fetch_directory or use the old fetch_directory] ****************************************************************************************************************************************
fatal: [undercloud]: FAILED! => {"msg": "The conditional check 'curl_get_http_status.stdout != \"200\"' failed. The error was: error while evaluating conditional (curl_get_http_status.stdout != \"200\"): 'dict object' has no attribute 'stdout'\n\nThe error appears to have been in '/home/stack/config-download/external_deploy_steps_tasks.yaml': line 215, column 7, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n        GET \"{{ swift_get_url }}\"\n    - fail:\n      ^ here\n"}
NO MORE HOSTS LEFT **************************************************************************************************************************************************************************************************
to retry, use: --limit @/home/stack/config-download/deploy_steps_playbook.retry
PLAY RECAP **********************************************************************************************************************************************************************************************************
ceph-0                     : ok=121  changed=47   unreachable=0    failed=0
ceph-1                     : ok=121  changed=47   unreachable=0    failed=0
ceph-2                     : ok=121  changed=47   unreachable=0    failed=0
compute-0                  : ok=142  changed=64   unreachable=0    failed=0
compute-1                  : ok=142  changed=64   unreachable=0    failed=0
controller-0               : ok=190  changed=102  unreachable=0    failed=0
controller-1               : ok=188  changed=101  unreachable=0    failed=0
controller-2               : ok=188  changed=101  unreachable=0    failed=0
undercloud                 : ok=30   changed=16   unreachable=0    failed=1


Expected results:

Dry run completes successfully

Additional info:

Comment 1 Gurenko Alex 2018-11-20 08:01:59 UTC
I've tested upstream patch on downstream puddle 2018-11-13.1 and dry-run completed successfully, waiting for downstream puddle with a fix.

Comment 4 Gurenko Alex 2018-11-22 13:07:42 UTC
Verified on puddle 2018-11-21.2

Comment 9 errata-xmlrpc 2019-01-11 11:54:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.