Bug 1651136 - [UPDATE] undercloud update for custom stack name is completed but it have post-upgrade error
Summary: [UPDATE] undercloud update for custom stack name is completed but it have po...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z7
: 13.0 (Queens)
Assignee: Carlos Camacho
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
: 1573120 1720080 (view as bug list)
Depends On:
Blocks: 1544752 1599764 1614478 1697873
TreeView+ depends on / blocked
 
Reported: 2018-11-19 09:37 UTC by Raviv Bar-Tal
Modified: 2019-08-26 11:23 UTC (History)
11 users (show)

Fixed In Version: instack-undercloud-8.4.7-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-10 13:03:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
undercloud_update.log (535.95 KB, text/plain)
2018-11-19 09:37 UTC, Raviv Bar-Tal
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 619112 0 'None' MERGED Get the stack name if possible before running the validations group 2020-11-19 09:34:23 UTC
OpenStack gerrit 657572 0 'None' MERGED Get the stack name if possible before running the validations group 2020-11-19 09:34:23 UTC
OpenStack gerrit 665006 0 'None' MERGED Fix stack_name reference 2020-11-19 09:34:46 UTC
Red Hat Product Errata RHBA-2019:1738 0 None None None 2019-07-10 13:05:16 UTC

Description Raviv Bar-Tal 2018-11-19 09:37:46 UTC
Created attachment 1507151 [details]
undercloud_update.log

Description of problem:
when using custom stack name like qe-Cloud-0 the undercloud update log shows the following error:
2018-11-18 11:12:23 | 2018-11-18 11:12:23,624 INFO: Starting and waiting for validation groups ['post-upgrade'] 
2018-11-18 11:12:51 | 2018-11-18 11:12:51,328 ERROR: ERROR error running the validation groups ['post-upgrade']   {"stderr": "[DEPRECATION WARNING]: DEFAULT_SUDO_FLAGS option, In favor of become which is a\n generic framework . This feature will be removed in version 2.8. Deprecation \nwarnings can be disabled by setting deprecation_warnings=False in ansible.cfg.\n", "stdout": "Task 'Fail if the HorizonPublic endpoint is not defined' failed:\nHost: undercloud\nMessage: The `HorizonPublic` endpoint is not defined in the `EndpointMap` of the deployed stack. This means Horizon may not have been deployed correctly.\n\nFailure! The validation failed for all hosts:\n* undercloud\n"} {"stderr": "[DEPRECATION WARNING]: DEFAULT_SUDO_FLAGS option, In favor of become which is a\n generic framework . This feature will be removed in version 2.8. Deprecation \nwarnings can be disabled by setting deprecation_warnings=False in ansible.cfg.\n/usr/lib/python2.7/site-packages/requests/packages/urllib3/connection.py:344: SubjectAltNameWarning: Certificate for 192.168.24.2 has no `subjectAltName`, falling back to check for a `commonName` for now. This feature is being removed by major browsers and deprecated by RFC 2818. (See https://github.com/shazow/urllib3/issues/497 for details.)\n  SubjectAltNameWarning\n", "stdout": "Task 'Check stack resource statuses' failed:\nHost: undercloud\nMessage: An unhandled exception occurred while running the lookup plugin 'stack_resources'. Error was a <class 'heatclient.exc.HTTPNotFound'>, original message: ERROR: The Stack (overcloud) could not be found.\n\nFailure! The validation failed for all hosts:\n* undercloud\n"} Mistral execution ID: 4aa85219-21b3-4f9f-b2f2-3e516f4c1881

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install ops13 with custom stack name like qe-Cloud-0  
2. run undercloud upgrade command
3.

Actual results:
post task fails 

Expected results:


Additional info:
More info can be found in the attached log and in Jenkins jobs:
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DFG/view/upgrades/view/update/job/DFG-upgrades-updates-13-from-ga-composable-ipv4-predictable/?auto_refresh=false

Comment 1 Carlos Camacho 2018-11-26 11:52:19 UTC
Still blocked because of an instack-undercloud issue

Comment 9 Alex Schultz 2019-06-12 19:32:03 UTC
FYI the current fix for this is resulting in an undercloud upgrade failure. See https://bugs.launchpad.net/tripleo/+bug/1832637

Comment 10 Alex Schultz 2019-06-13 22:14:11 UTC
Moving this back to ON_DEV and adding a blocker as the current version of this fix will break customers ability to upgrade when they have validations enabled.  I have proposed a fix upstream for the issue.

Comment 12 Carlos Camacho 2019-06-19 10:08:18 UTC
*** Bug 1720080 has been marked as a duplicate of this bug. ***

Comment 21 errata-xmlrpc 2019-07-10 13:03:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1738

Comment 22 Jose Luis Franco 2019-08-26 11:23:33 UTC
*** Bug 1573120 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.