Bug 1651170 - Undercloud installation fails with Keystone not available, command openstack token issue --format value
Summary: Undercloud installation fails with Keystone not available, command openstack ...
Keywords:
Status: CLOSED DUPLICATE of bug 1651032
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-19 10:48 UTC by Raoul Scarazzini
Modified: 2018-11-19 14:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 14:21:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Raoul Scarazzini 2018-11-19 10:48:52 UTC
Description of problem:

Undercloud installation is consistently failing with this message:

2018-11-16 12:50:48 | 2018-11-16 12:50:48 - Error: /Stage[main]/Keystone::Roles::Admin/Keystone_user[admin]: Could not evaluate: Execution of '/bin/openstack token issue --format value' returned 1: Unable to establish connection to https://192.168.24.2:13000/v3/auth/tokens: HTTPSConnectionPool(host='192.168.24.2', port=13000): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7fe7aa0aa050>: Failed to establish a new connection: [Errno 111] Connection refused',)) (tried 47, for a total of 170 seconds)

then the grants on MySQL are not configured:

2018-11-16 12:51:57 | 2018-11-16 12:51:57 - Notice: /Stage[main]/Heat::Db::Sync/Exec[heat-dbsync]/returns: ERROR: (pymysql.err.OperationalError) (1045, u"Access denied for user 'heat'@'192.168.24.1' (using password: YES)")
2018-11-16 12:51:57 | 2018-11-16 12:51:57 - Error: /Stage[main]/Heat::Db::Sync/Exec[heat-dbsync]: Failed to call refresh: heat-manage --config-file /etc/heat/heat.conf db_sync returned 1 instead of one of [0]
2018-11-16 12:51:57 | 2018-11-16 12:51:57 - Error: /Stage[main]/Heat::Db::Sync/Exec[heat-dbsync]: heat-manage --config-file /etc/heat/heat.conf db_sync returned 1 instead of one of [0]

and so everything fails:

2018-11-16 12:52:05 | [2018-11-16 12:52:05,242] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]
2018-11-16 12:52:05 | [2018-11-16 12:52:05,243] (os-refresh-config) [ERROR] Aborting...
2018-11-16 12:52:05 |     raise RuntimeError('%s failed. See log for details.' % name)
2018-11-16 12:52:05 | RuntimeError: os-refresh-config failed. See log for details.

Version-Release number of selected component (if applicable):

Puddle 2018-11-15.2

How reproducible:

The failure is consistent.

Steps to Reproduce:
1. openstack undercloud install

Actual results:

Undercloud install fails.

Expected results:

Undercloud install succeeds.

Additional info:

sosreport from the undercloud to be attached in short.

Comment 2 Michele Baldessari 2018-11-19 14:21:04 UTC
Nov 16 12:45:24 undercloud systemd[1]: haproxy.service: main process exited, code=exited, status=1/FAILURE
Nov 16 12:45:24 undercloud systemd[1]: Unit haproxy.service entered failed state.
Nov 16 12:45:24 undercloud systemd[1]: haproxy.service failed.

*** This bug has been marked as a duplicate of bug 1651032 ***


Note You need to log in before you can comment on or make changes to this bug.