Bug 1651220 - Require Ansible 2.7+
Summary: Require Ansible 2.7+
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-ansible-roles
Classification: oVirt
Component: General
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.3.0
: ---
Assignee: Ondra Machacek
QA Contact: Martin Perina
Rolfe Dlugy-Hegwer
URL:
Whiteboard:
Depends On:
Blocks: 1651227
TreeView+ depends on / blocked
 
Reported: 2018-11-19 13:15 UTC by Martin Perina
Modified: 2019-04-08 10:44 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.3.0_rc
Doc Type: Release Note
Doc Text:
This release adds a requirement for Ansible version 2.7, the lowest version required to run oVirt Ansible roles.
Clone Of:
: 1651227 (view as bug list)
Environment:
Last Closed: 2019-02-13 07:44:59 UTC
oVirt Team: Infra
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github oVirt ovirt-ansible-cluster-upgrade pull 33 None None None 2018-11-20 11:42:21 UTC
Github oVirt ovirt-ansible-infra pull 50 None None None 2018-11-20 09:17:40 UTC
Github oVirt ovirt-ansible-manageiq pull 72 None None None 2018-11-20 10:24:58 UTC
Github oVirt ovirt-ansible-vm-infra pull 59 None None None 2018-11-20 09:17:57 UTC
oVirt gerrit 96263 master MERGED packaging: Require Ansible 2.7.2 2018-12-18 09:42:18 UTC
oVirt gerrit 96283 None None None 2018-12-18 09:58:21 UTC

Description Martin Perina 2018-11-19 13:15:38 UTC
Ansible 2.7.2 or higher is required to execute oVirt Ansible roles. This bump will allow us to remove all modules updates from 2.5 to 2.7.2, which were part of our roles.

Comment 2 Rolfe Dlugy-Hegwer 2019-01-21 12:32:05 UTC
Ondra. Please review the current Doc Type and Doc Text. Thank you.

Comment 3 Martin Perina 2019-01-21 14:40:17 UTC
(In reply to Rolfe Dlugy-Hegwer from comment #2)
> Ondra. Please review the current Doc Type and Doc Text. Thank you.

Looks good to me

Comment 4 Martin Perina 2019-01-28 11:40:45 UTC
# rpm -q ovirt-engine
ovirt-engine-4.3.0.1-1.el7.noarch

# rpm -q --requires ovirt-engine | grep ansible
ansible >= 2.7.2
ovirt-ansible-roles >= 1.1.6


# rpm -q --requires ovirt-ansible-roles | grep ansible
ansible >= 2.7.2
ovirt-ansible-cluster-upgrade >= 1.1.9
ovirt-ansible-disaster-recovery >= 0.1
ovirt-ansible-engine-setup >= 1.1.6
ovirt-ansible-hosted-engine-setup >= 1.0.0
ovirt-ansible-image-template >= 1.1.9
ovirt-ansible-infra >= 1.1.10
ovirt-ansible-manageiq >= 1.1.13
ovirt-ansible-repositories >= 1.1.3
ovirt-ansible-shutdown-env >= 1.0.0
ovirt-ansible-v2v-conversion-host >= 1.0.0
ovirt-ansible-vm-infra >= 1.1.12


# rpm -q --requires ovirt-ansible-cluster-upgrade | grep ansible
ansible >= 2.7.2


# rpm -q --requires ovirt-ansible-disaster-recovery | grep ansible
ansible >= 2.7.2


# rpm -q --requires ovirt-ansible-engine-setup | grep ansible
ansible >= 2.7.2


# rpm -q --requires ovirt-ansible-image-template | grep ansible
ansible >= 2.7.2


# rpm -q --requires ovirt-ansible-infra | grep ansible
ansible >= 2.7.2


# rpm -q --requires ovirt-ansible-manageiq | grep ansible
ansible >= 2.7.2


# rpm -q --requires ovirt-ansible-repositories | grep ansible
ansible >= 2.7.2


# rpm -q --requires ovirt-ansible-vm-infra | grep ansible
ansible >= 2.7.2


# rpm -q --requires ovirt-ansible-hosted-engine-setup | grep ansible
ansible >= 2.7
ovirt-ansible-engine-setup >= 1.1.5
ovirt-ansible-repositories >= 1.1.2


# rpm -q --requires ovirt-ansible-shutdown-env | grep ansible
ansible >= 2.7
This is OK, because above role will be updated as a part of BZ1666290




# rpm -q --requires ovirt-ansible-v2v-conversion-host | grep ansible
ansible >= 2.4
This is OK, as above role is used also in other products, where we cannot bump Ansible version to 2.7

Comment 5 Sandro Bonazzola 2019-02-13 07:44:59 UTC
This bugzilla is included in oVirt 4.3.0 release, published on February 4th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.