Bug 1651224 - Ugrade based on label doen't work as expected for 3.11
Summary: Ugrade based on label doen't work as expected for 3.11
Keywords:
Status: CLOSED DUPLICATE of bug 1649074
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-19 13:22 UTC by Abhishek
Modified: 2018-11-19 13:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 13:26:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Abhishek 2018-11-19 13:22:48 UTC
Description of problem: Upgrading OCP cluster from 3.10 to 3.11 based on labels and it skipped the match and upgrade all the nodes.As `/usr/bin/oc get node --selector=<key>=<value> -o json -n default` command output gives shot hostname and failed while matching with FQDN mentioned in the inventory file. 

How reproducible:
Always

Steps to Reproduce:
1.oc get nodes output shortname
2.If you are passing FQDN in the inventory and running upgrade playbook (based on label)

Comment 1 Scott Dodson 2018-11-19 13:26:19 UTC

*** This bug has been marked as a duplicate of bug 1649074 ***


Note You need to log in before you can comment on or make changes to this bug.