Bug 1651258 - rhnpush This file doesn't appear to be a package
Summary: rhnpush This file doesn't appear to be a package
Keywords:
Status: CLOSED EOL
Alias: None
Product: Spacewalk
Classification: Community
Component: API
Version: 2.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Dobes
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-19 14:41 UTC by SAMO
Modified: 2020-03-09 13:37 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-09 13:37:56 UTC


Attachments (Terms of Use)

Description SAMO 2018-11-19 14:41:49 UTC
Description of problem:

I am trying to sync Ubuntu package to Spacewalk Server 2.8, however for some package I am facing the error:

/tmp/dbus-x11_1.6.18-0ubuntu4.4_amd64.deb: This file doesn't appear to be a package

Version-Release number of selected component (if applicable):


How reproducible:

I am using this script to sync, it bascially download the package and then uses rhnpush:
https://github.com/philicious/spacewalk-scripts/blob/master/debianSync.py

I got then rhn error:

INFO: 5/5894: dbus-x11_1.6.18-0ubuntu4.4_amd64.deb
ERROR: rhnpush [ rhnpush -c trusty-security -u autoliv-errata -p 515ilNJufm13aliuWW3d /tmp/dbus-x11_1.6.18-0ubuntu4.4_amd64.deb ] failed: ('', "ERROR: /tmp/dbus-x11_1.6.18-0ubuntu4.4_amd64.deb: This file doesn't appear to be a package\n")


Steps to Reproduce:
1. run the script
2. pacakge is downloaded
3. rhn error is thrown

Actual results:
package is not imported

Expected results:
package to be pushed to spacewalk

Additional info:

Comment 1 Michael Mráka 2020-03-09 13:37:56 UTC
Spacewalk 2.8 (and older) has already reached it's End Of Life.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before end of life. If you would still like
to see this bug fixed and are able to reproduce it against current version
of Spacewalk 2.9, you are encouraged change the 'version' and re-open it.


Note You need to log in before you can comment on or make changes to this bug.