Bug 1651337 - Update DPDK to 18.11 [NEEDINFO]
Summary: Update DPDK to 18.11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dpdk
Version: 7.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Timothy Redaelli
QA Contact: Jean-Tsung Hsiao
URL:
Whiteboard:
: 1642707 1654955 (view as bug list)
Depends On:
Blocks: 1563290 1560143 1662151
TreeView+ depends on / blocked
 
Reported: 2018-11-19 18:06 UTC by Timothy Redaelli
Modified: 2020-02-10 21:55 UTC (History)
16 users (show)

Fixed In Version: dpdk-18.11-1.el7_6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 19:13:11 UTC
Target Upstream Version:
ailan: needinfo? (atragler)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0233 0 None None None 2019-01-31 19:13:13 UTC

Internal Links: 1654955

Description Timothy Redaelli 2018-11-19 18:06:44 UTC

Comment 5 Timothy Redaelli 2018-11-30 09:49:40 UTC
*** Bug 1654955 has been marked as a duplicate of this bug. ***

Comment 6 Timothy Redaelli 2018-12-06 16:54:24 UTC
*** Bug 1642707 has been marked as a duplicate of this bug. ***

Comment 13 Jean-Tsung Hsiao 2019-01-14 00:49:24 UTC
For dpdk 18.11 testing I have done 64 bytes 0-loss PvP tests for Rhel-7.6 and Rhel-8.0 tests over OVS-dpdk/ixgbe --- Each test using 60 seconds searching and 600 seconds valalidation. Here are the Mpps results: 

Rhel-7.6 vIOMMU Guest/Rhel-8.0 Host

1Q/2PMD --- 4.62 Mpps
2Q/4PMD --- 7.18 Mpps

Rhel-8.0 vIOMMU Guest/Rhel-8.0 Host

1Q/2PMD --- 4.62 Mpps
2Q/4PMD --- 7.55 Mpps

Other tests

PvP 64 bytes 0-loss tests over OVS-dpdk/nfp: 1Q/2PMD, 2Q/4PMD.

P2P 64 bytes 0-loss testpmd/ixgbe tests: 23 Mpps

Comment 18 Takuma Umeya 2019-01-16 21:17:44 UTC
Dear partner, 
Red Hat would like your collaboration in testing this feature once incorporated with the RHEL7 release. Please make a response on whether you are able to test and verify this feature. 
Please reach out to your EPM if you have any questions. 
Thanks,

Comment 20 Pei Zhang 2019-01-18 07:04:20 UTC
Hi Sitong, 

Could you please also update your testing results of dpdk18.11 on rhel8? Thanks a lot for your efforts.


Best regards,
Pei

Comment 21 Sitong Liu 2019-01-18 08:11:48 UTC
(In reply to Pei Zhang from comment #20)
> Hi Sitong, 
> 
> Could you please also update your testing results of dpdk18.11 on rhel8?
> Thanks a lot for your efforts.
> 
> 
> Best regards,
> Pei

Hi Pei,

Function test and live migration test for dpdk-18.11-2.el8.x86_64 got pass on our env,
no regression bug was found for dpdk.

Test versions:
qemu-kvm-3.1.0-3.module+el8+2614+d714d2bb
dpdk-18.11-2.el8.x86_64
openvswitch2.10-2.10.0-28.el8fdb

Test scenarios are same with Comment 19.

Best regards,
Sitong

Comment 22 Sitong Liu 2019-01-18 08:30:38 UTC
Tests in Comment 19 and Comment 21 are with ixgbe driver.

Comment 28 errata-xmlrpc 2019-01-31 19:13:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0233


Note You need to log in before you can comment on or make changes to this bug.