Bug 16514 - proxy-mod has problems with some ftp sites
Summary: proxy-mod has problems with some ftp sites
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-18 08:23 UTC by vek
Modified: 2007-04-18 16:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 09:55:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description vek 2000-08-18 08:23:34 UTC
When using apache as a proxy server you get problems with some ftp sites.
The symptom is that the transfer stalls at the end of the transfer.

The apache proxy server is supposed to close the data socket at the end
of a FTP data transfer before reading the control socket.  The apache
module does it in the other sequence.

There is an open bug report in the apache bug register under
the component proxy-mod, keyword ftp.  You may look there for further
information.


Villy

Comment 1 Henri Schlereth 2000-08-20 17:21:48 UTC
Unable to duplicate. Please upgrade to a more current version from 6.2-Rawhide-Pinstripe and re-test with more data.

Henri J.Schlereth
RH Beta Team

Comment 2 vek 2000-08-21 10:36:06 UTC
As the Apache group has not fixed the bug amn there is no redhat
supplied patches that fixes it in version 1.3.12-20, the bug must be
present in this version as well.

Check the Apache bug archive for bug number 6268 and 5562.  Also check
the latest changes to wu-ftpd for the changes that makes this problem 
appear in apache and why this change was made to wu-ftpd.  These 
reports also givse information on how to reproduce the problem, as the 
problem may not have shown up with the sites you have tested.


The entry for PR6268 in the apache bug list contains a patch that is supposed
to fix this.  The Apache group has not reported whether this has been tested 
by them or if this is indeed the proper patch for this problem.  It works
for me, though.



Villy

Comment 3 Joe Orton 2004-09-21 09:55:21 UTC
Thanks for the report.  Since this release of Red Hat Linux is no
longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) try and reproduce this bug using the current version of the
upstream package, and report the bug upstream.



Note You need to log in before you can comment on or make changes to this bug.