Bug 1651431 - Resolve memory leak at the time of graph init
Summary: Resolve memory leak at the time of graph init
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: Mohit Agrawal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-20 04:11 UTC by Mohit Agrawal
Modified: 2019-03-25 16:32 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:32:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21658 None Merged core: Resolve memory leak at the time of graph init 2018-11-20 09:38:39 UTC
Gluster.org Gerrit 21695 None Merged core: Resolve memory leak at the time of graph init 2018-11-22 12:52:22 UTC

Description Mohit Agrawal 2018-11-20 04:11:54 UTC
Description of problem:
Resolve memory leak at the time of calling glusterfs_graph_init if graph_init fails

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Due to this memory leak if no. of volumes are high and brick_mux is enabled brick process is consuming high memory and due to the high memory consumption kernel sends a kill signal to the brick process.

Expected results:
There should not be memory leak at the brick process.

Additional info:

Comment 1 Worker Ant 2018-11-20 04:17:00 UTC
REVIEW: https://review.gluster.org/21658 (core: Resolve memory leak at the time of graph init) posted (#5) for review on master by MOHIT AGRAWAL

Comment 2 Worker Ant 2018-11-20 09:38:38 UTC
REVIEW: https://review.gluster.org/21658 (core: Resolve memory leak at the time of graph init) posted (#6) for review on master by Amar Tumballi

Comment 3 Worker Ant 2018-11-21 13:35:45 UTC
REVIEW: https://review.gluster.org/21695 (core: Resolve memory leak at the time of graph init) posted (#4) for review on master by MOHIT AGRAWAL

Comment 4 Worker Ant 2018-11-22 12:52:20 UTC
REVIEW: https://review.gluster.org/21695 (core: Resolve memory leak at the time of graph init) posted (#9) for review on master by Xavi Hernandez

Comment 5 Shyamsundar 2019-03-25 16:32:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.